summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAkinori Hattori <hattya@gentoo.org>2018-08-28 22:40:12 +0900
committerAkinori Hattori <hattya@gentoo.org>2018-08-28 22:40:12 +0900
commit833f267f753b1d84149a30b7b161debbf2125a2a (patch)
tree6017cef9c78b60713693ed75243573f4a359d6ac /app-i18n/imhangul/imhangul-2.1.0-r1.ebuild
parentapp-i18n/libhangul: update HOMEPAGE and SRC_URI (diff)
downloadgentoo-833f267f753b1d84149a30b7b161debbf2125a2a.tar.gz
gentoo-833f267f753b1d84149a30b7b161debbf2125a2a.tar.bz2
gentoo-833f267f753b1d84149a30b7b161debbf2125a2a.zip
app-i18n/imhangul: tidy
Package-Manager: Portage-2.3.40, Repoman-2.3.9
Diffstat (limited to 'app-i18n/imhangul/imhangul-2.1.0-r1.ebuild')
-rw-r--r--app-i18n/imhangul/imhangul-2.1.0-r1.ebuild58
1 files changed, 58 insertions, 0 deletions
diff --git a/app-i18n/imhangul/imhangul-2.1.0-r1.ebuild b/app-i18n/imhangul/imhangul-2.1.0-r1.ebuild
new file mode 100644
index 000000000000..5f32412487aa
--- /dev/null
+++ b/app-i18n/imhangul/imhangul-2.1.0-r1.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+inherit gnome2-utils
+
+DESCRIPTION="GTK+ 2 Hangul Input Modules"
+HOMEPAGE="https://code.google.com/p/imhangul/"
+SRC_URI="https://imhangul.googlecode.com/files/${P}.tar.bz2"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="amd64 ppc x86"
+IUSE=""
+
+RDEPEND="app-i18n/libhangul
+ x11-libs/gtk+:2
+ virtual/libintl"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ sys-devel/gettext"
+
+src_prepare() {
+ default
+ gnome2_environment_reset
+ gnome2_disable_deprecation_warning
+}
+
+src_configure() {
+ econf --with-gtk-im-module-dir="${EPREFIX%/}"/usr/$(get_libdir)/gtk-2.0/$(pkg-config gtk+-2.0 --variable=gtk_binary_version)/immodules
+}
+
+src_install() {
+ default
+ find "${ED}" -name '*.la' -delete || die
+ dodoc ${PN}.conf
+
+ local s
+ insinto /etc/X11/xinit/xinput.d
+ for s in 2{,y} 3{2,9,f,s,y} ahn ro; do
+ newins "${FILESDIR}"/xinput-${PN}${s} ${PN}${s}.conf
+ done
+}
+
+pkg_postinst() {
+ gnome2_query_immodules_gtk2
+ elog
+ elog "If you want to use one of the module as a default input method, "
+ elog
+ elog "export GTK_IM_MODULE=hangul2 # 2 input type"
+ elog "export GTK_IM_MODULE=hangul3f # 3 input type"
+ elog
+}
+
+pkg_postrm() {
+ gnome2_query_immodules_gtk2
+}