summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-04-07 06:17:56 +0100
committerSam James <sam@gentoo.org>2021-04-13 00:26:33 +0000
commita3955aa4ce98b8c52115e3228a1cfb623a90d1de (patch)
treea89ce5de7f4e4eb5c73985f6c664342a6c7807a6 /app-i18n/imhangul/imhangul-2.1.0-r1.ebuild
parentx11-wm/windowlab: call pkg-config via toolchain-funcs.eclass helper (diff)
downloadgentoo-a3955aa4ce98b8c52115e3228a1cfb623a90d1de.tar.gz
gentoo-a3955aa4ce98b8c52115e3228a1cfb623a90d1de.tar.bz2
gentoo-a3955aa4ce98b8c52115e3228a1cfb623a90d1de.zip
app-i18n/imhangul: call pkg-config via toolchain-funcs.eclass helper
This ensures we call the correct pkg-config in e.g. cross. Package-Manager: Portage-3.0.14-prefix, Repoman-3.0.2 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-i18n/imhangul/imhangul-2.1.0-r1.ebuild')
-rw-r--r--app-i18n/imhangul/imhangul-2.1.0-r1.ebuild6
1 files changed, 3 insertions, 3 deletions
diff --git a/app-i18n/imhangul/imhangul-2.1.0-r1.ebuild b/app-i18n/imhangul/imhangul-2.1.0-r1.ebuild
index fa3a74b4b503..22f7c57fe635 100644
--- a/app-i18n/imhangul/imhangul-2.1.0-r1.ebuild
+++ b/app-i18n/imhangul/imhangul-2.1.0-r1.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI="6"
-inherit gnome2-utils
+inherit gnome2-utils toolchain-funcs
DESCRIPTION="GTK+ 2 Hangul Input Modules"
HOMEPAGE="https://github.com/libhangul/imhangul"
@@ -28,7 +28,7 @@ src_prepare() {
}
src_configure() {
- econf --with-gtk-im-module-dir="${EPREFIX}"/usr/$(get_libdir)/gtk-2.0/$(pkg-config gtk+-2.0 --variable=gtk_binary_version)/immodules
+ econf --with-gtk-im-module-dir="${EPREFIX}"/usr/$(get_libdir)/gtk-2.0/$($(tc-getPKG_CONFIG) gtk+-2.0 --variable=gtk_binary_version)/immodules
}
src_install() {