summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2019-08-18 14:53:27 +0200
committerDavid Seifert <soap@gentoo.org>2019-08-18 14:53:27 +0200
commit4b18bb8e01438a52147cb94e94085bf753fdefd3 (patch)
treeeef27c38e7c886aba9a340ed199bf79631f654e3 /app-i18n/kcc/kcc-1.0.ebuild
parentmedia-video/aegisub: [QA] Fix leading whitespace (diff)
downloadgentoo-4b18bb8e01438a52147cb94e94085bf753fdefd3.tar.gz
gentoo-4b18bb8e01438a52147cb94e94085bf753fdefd3.tar.bz2
gentoo-4b18bb8e01438a52147cb94e94085bf753fdefd3.zip
app-i18n/kcc: Port to EAPI 7
Package-Manager: Portage-2.3.71, Repoman-2.3.17 Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'app-i18n/kcc/kcc-1.0.ebuild')
-rw-r--r--app-i18n/kcc/kcc-1.0.ebuild29
1 files changed, 14 insertions, 15 deletions
diff --git a/app-i18n/kcc/kcc-1.0.ebuild b/app-i18n/kcc/kcc-1.0.ebuild
index bcb220713949..20ee1ee57350 100644
--- a/app-i18n/kcc/kcc-1.0.ebuild
+++ b/app-i18n/kcc/kcc-1.0.ebuild
@@ -1,34 +1,33 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI="4"
+EAPI=7
-inherit eutils toolchain-funcs
+inherit toolchain-funcs
DESCRIPTION="A Kanji code converter"
HOMEPAGE="http://www2s.biglobe.ne.jp/~Nori/ruby/"
-SRC_URI="ftp://ftp.jp.freebsd.org/pub/FreeBSD/ports/distfiles/${PN}.tar.gz"
+SRC_URI="mirror://gentoo/${PN}.tar.gz -> ${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 x86"
-IUSE=""
S="${WORKDIR}/${PN}"
-
-src_prepare() {
- epatch "${FILESDIR}/${PN}-gcc3-gentoo.diff"
- epatch "${FILESDIR}/${PN}-exit.diff"
- sed -i "s:\(-o kcc\):\$(LDFLAGS) \1:" Makefile
-}
-
-src_compile() {
- emake CC="$(tc-getCC)" CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}"
+PATCHES=(
+ "${FILESDIR}"/${PN}-gcc3-gentoo.diff
+ "${FILESDIR}"/${PN}-exit.diff
+ "${FILESDIR}"/${PN}-1.0-fix-build-system.patch
+)
+
+src_configure() {
+ tc-export CC
}
src_install() {
dobin kcc
- dodoc README
+ einstalldocs
+
cp -f kcc.jman kcc.1 || die
doman -i18n=ja kcc.1
}