summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <Arfrever@Apache.Org>2017-08-22 15:43:15 +0200
committerMike Gilbert <floppym@gentoo.org>2017-08-22 10:20:17 -0400
commit19100e2bb6c5b802e0974243614d4b7aa67c9130 (patch)
tree822d226e0da2879755ef5ecb1e16cc4e84280d8d /app-i18n/kcm-fcitx/kcm-fcitx-0.5.4.ebuild
parentapp-i18n/kcm-fcitx: Update dependency on app-i18n/fcitx-qt5. (diff)
downloadgentoo-19100e2bb6c5b802e0974243614d4b7aa67c9130.tar.gz
gentoo-19100e2bb6c5b802e0974243614d4b7aa67c9130.tar.bz2
gentoo-19100e2bb6c5b802e0974243614d4b7aa67c9130.zip
app-i18n/kcm-fcitx: Version bump (0.5.4).
Diffstat (limited to 'app-i18n/kcm-fcitx/kcm-fcitx-0.5.4.ebuild')
-rw-r--r--app-i18n/kcm-fcitx/kcm-fcitx-0.5.4.ebuild60
1 files changed, 60 insertions, 0 deletions
diff --git a/app-i18n/kcm-fcitx/kcm-fcitx-0.5.4.ebuild b/app-i18n/kcm-fcitx/kcm-fcitx-0.5.4.ebuild
new file mode 100644
index 000000000000..59ff589971aa
--- /dev/null
+++ b/app-i18n/kcm-fcitx/kcm-fcitx-0.5.4.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+inherit cmake-utils
+
+if [[ "${PV}" =~ (^|\.)9999$ ]]; then
+ inherit git-r3
+
+ EGIT_REPO_URI="https://github.com/fcitx/kcm-fcitx"
+fi
+
+DESCRIPTION="KDE configuration module for Fcitx"
+HOMEPAGE="https://fcitx-im.org/ https://github.com/fcitx/kcm-fcitx"
+if [[ "${PV}" =~ (^|\.)9999$ ]]; then
+ SRC_URI=""
+else
+ SRC_URI="https://download.fcitx-im.org/${PN}/${P}.tar.xz"
+fi
+
+LICENSE="GPL-2+"
+SLOT="5"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=app-i18n/fcitx-4.2.8
+ >=app-i18n/fcitx-qt5-1.1
+ dev-qt/qtcore:5
+ dev-qt/qtdbus:5
+ dev-qt/qtgui:5
+ dev-qt/qtwidgets:5
+ kde-frameworks/kcmutils:5
+ kde-frameworks/kcoreaddons:5
+ kde-frameworks/ki18n:5
+ kde-frameworks/kio:5
+ kde-frameworks/kitemviews:5
+ kde-frameworks/knewstuff:5
+ kde-frameworks/kwidgetsaddons:5
+ virtual/libintl
+ !${CATEGORY}/${PN}:4[-minimal(-)]"
+DEPEND="${RDEPEND}
+ kde-frameworks/extra-cmake-modules:5
+ sys-devel/gettext
+ virtual/pkgconfig"
+
+src_prepare() {
+ # x11-libs/libxkbfile only used by kbd-layout-viewer not ported to Qt 5 / KDE 5.
+ sed -e "/find_package(XkbFile REQUIRED)/d" -i CMakeLists.txt
+
+ cmake-utils_src_prepare
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DKDE_INSTALL_USE_QT_SYS_PATHS=yes
+ )
+
+ cmake-utils_src_configure
+}