summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <Arfrever@Apache.Org>2017-09-21 20:56:19 +0200
committerMike Gilbert <floppym@gentoo.org>2017-09-21 17:03:58 -0400
commit8033f0f87f6e0198fa5da0a23657c8d71a2e4b09 (patch)
tree61828edffb6b7fa9a9b432ffae4b14790d325bc1 /app-i18n/kcm-fcitx/kcm-fcitx-0.5.5.ebuild
parentapp-i18n/kcm-fcitx: Specify slot in dependencies on app-i18n/fcitx and app-i1... (diff)
downloadgentoo-8033f0f87f6e0198fa5da0a23657c8d71a2e4b09.tar.gz
gentoo-8033f0f87f6e0198fa5da0a23657c8d71a2e4b09.tar.bz2
gentoo-8033f0f87f6e0198fa5da0a23657c8d71a2e4b09.zip
app-i18n/kcm-fcitx: Version bump (0.5.5).
Diffstat (limited to 'app-i18n/kcm-fcitx/kcm-fcitx-0.5.5.ebuild')
-rw-r--r--app-i18n/kcm-fcitx/kcm-fcitx-0.5.5.ebuild56
1 files changed, 56 insertions, 0 deletions
diff --git a/app-i18n/kcm-fcitx/kcm-fcitx-0.5.5.ebuild b/app-i18n/kcm-fcitx/kcm-fcitx-0.5.5.ebuild
new file mode 100644
index 000000000000..7d7699c83eb9
--- /dev/null
+++ b/app-i18n/kcm-fcitx/kcm-fcitx-0.5.5.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+inherit cmake-utils
+
+if [[ "${PV}" =~ (^|\.)9999$ ]]; then
+ inherit git-r3
+
+ EGIT_REPO_URI="https://github.com/fcitx/kcm-fcitx"
+fi
+
+DESCRIPTION="KDE configuration module for Fcitx"
+HOMEPAGE="https://fcitx-im.org/ https://github.com/fcitx/kcm-fcitx"
+if [[ "${PV}" =~ (^|\.)9999$ ]]; then
+ SRC_URI=""
+else
+ SRC_URI="https://download.fcitx-im.org/${PN}/${P}.tar.xz"
+fi
+
+LICENSE="GPL-2+"
+SLOT="4-plasma5"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=app-i18n/fcitx-4.2.9:4
+ >=app-i18n/fcitx-qt5-1.1:4
+ dev-qt/qtcore:5
+ dev-qt/qtdbus:5
+ dev-qt/qtgui:5
+ dev-qt/qtwidgets:5
+ dev-qt/qtx11extras:5
+ kde-frameworks/kconfigwidgets:5
+ kde-frameworks/kcoreaddons:5
+ kde-frameworks/ki18n:5
+ kde-frameworks/kio:5
+ kde-frameworks/kitemviews:5
+ kde-frameworks/knewstuff:5
+ kde-frameworks/kwidgetsaddons:5
+ virtual/libintl
+ x11-libs/libX11
+ x11-libs/libxkbfile
+ !${CATEGORY}/${PN}:4[-minimal(-)]"
+DEPEND="${RDEPEND}
+ kde-frameworks/extra-cmake-modules:5
+ sys-devel/gettext
+ virtual/pkgconfig"
+
+src_configure() {
+ local mycmakeargs=(
+ -DKDE_INSTALL_USE_QT_SYS_PATHS=yes
+ )
+
+ cmake-utils_src_configure
+}