summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAkinori Hattori <hattya@gentoo.org>2017-08-17 00:03:49 +0900
committerAkinori Hattori <hattya@gentoo.org>2017-08-17 00:03:49 +0900
commite6bef3cffebd5442f37fc99d96cd613d845ef2b2 (patch)
tree67a0a0c7879c14f638fa1d300673a5f022f53c72 /app-i18n/libchewing/files
parentapp-i18n/ibus-fbterm: update DESCRIPTION (diff)
downloadgentoo-e6bef3cffebd5442f37fc99d96cd613d845ef2b2.tar.gz
gentoo-e6bef3cffebd5442f37fc99d96cd613d845ef2b2.tar.bz2
gentoo-e6bef3cffebd5442f37fc99d96cd613d845ef2b2.zip
dev-libs/libchewing: move to app-i18n/libchewing
Diffstat (limited to 'app-i18n/libchewing/files')
-rw-r--r--app-i18n/libchewing/files/0.3.3-cflags.patch10
-rw-r--r--app-i18n/libchewing/files/0.3.3-strncat-fix.patch13
-rw-r--r--app-i18n/libchewing/files/0.3.3-tinfo.patch43
3 files changed, 66 insertions, 0 deletions
diff --git a/app-i18n/libchewing/files/0.3.3-cflags.patch b/app-i18n/libchewing/files/0.3.3-cflags.patch
new file mode 100644
index 000000000000..dba1093c5ae6
--- /dev/null
+++ b/app-i18n/libchewing/files/0.3.3-cflags.patch
@@ -0,0 +1,10 @@
+--- a/configure.ac
++++ b/configure.ac
+@@ -153,7 +122,6 @@
+ if test x$LIBDEBUG = x"true"; then
+ AC_DEFINE(ENABLE_DEBUG, 1,
+ [Define to 1 if you want native library runtime debugging code enabled])
+- CFLAGS="$CFLAGS -g"
+ fi
+ AC_SUBST(LIBDEBUG)
+
diff --git a/app-i18n/libchewing/files/0.3.3-strncat-fix.patch b/app-i18n/libchewing/files/0.3.3-strncat-fix.patch
new file mode 100644
index 000000000000..8f2676c0c2b7
--- /dev/null
+++ b/app-i18n/libchewing/files/0.3.3-strncat-fix.patch
@@ -0,0 +1,13 @@
+diff --git a/src/tree.c b/src/tree.c
+index 7e8f665..89ad0d5 100644
+--- a/src/tree.c
++++ b/src/tree.c
+@@ -586,7 +586,7 @@ static void LoadChar( char *buf, int buf_len, uint16 phoneSeq[], int nPhoneSeq )
+ memset(buf, 0, buf_len);
+ for ( i = 0; i < nPhoneSeq; i++ ) {
+ GetCharFirst( &word, phoneSeq[ i ] );
+- strncat(buf, word.word, buf_len);
++ strncat(buf, word.word, buf_len - strlen(buf) - 1);
+ }
+ buf[ buf_len - 1 ] = '\0';
+ }
diff --git a/app-i18n/libchewing/files/0.3.3-tinfo.patch b/app-i18n/libchewing/files/0.3.3-tinfo.patch
new file mode 100644
index 000000000000..10692e72c8ed
--- /dev/null
+++ b/app-i18n/libchewing/files/0.3.3-tinfo.patch
@@ -0,0 +1,43 @@
+--- a/configure.ac
++++ b/configure.ac
+@@ -91,38 +91,8 @@
+ AM_CONDITIONAL(ENABLE_UNIT_TEST, test x$enable_check = "xyes")
+
+ # Checks for ncursesw
+-OLDCFLAGS=$CFLAGS
+-LIB_NAME=ncursesw
+-NCURSESW_CFLAGS=
+-NCURSESW_LIBS=
+-for p in "$HOME/include" "$prefix/include" /usr/local/include /usr/include
+-do
+- if test -f "$p/ncursesw/ncurses.h"
+- then
+- NCURSESW_CFLAGS="-I$p"
+- AC_DEFINE(HAVE_NCURSESW_NCURSES_H, 1, [ Define to 1 if you have the <ncursesw/ncurses.h> header file. ])
+- break
+- elif test -f "$p/ncurses/ncurses.h"
+- then
+- NCURSESW_CFLAGS="-I$p"
+- AC_DEFINE(HAVE_NCURSES_NCURSES_H, 1, [ Define to 1 if you have the <ncurses/ncurses.h> header file. ])
+- break
+- fi
+-done
+-
+-for p in "$HOME/lib" "$prefix/lib" /usr/local/lib /usr/lib
+-do
+- if test -f "$p/libncursesw.so"
+- then
+- if test "$p" != x/usr/lib
+- then
+- NCURSESW_LIBS="-L$p -lncursesw"
+- else
+- NCURSESW_LIBS="-lncursesw"
+- fi
+- break
+- fi
+-done
++PKG_CHECK_MODULES(NCURSESW,ncursesw,
++ AC_DEFINE(HAVE_NCURSESW_NCURSES_H, 1, [ Define to 1 if you have the <ncursesw/ncurses.h> header file. ]),)
+
+ enable_ncursesw=yes
+ if test -z "$NCURSESW_CFLAGS"; then