summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <Arfrever@Apache.Org>2017-09-16 22:19:43 +0200
committerMike Gilbert <floppym@gentoo.org>2017-09-18 14:31:02 -0400
commitccc64d31a21cef545ea9d82d5e18401694d093a6 (patch)
tree5cf139cff4d197f0ccb5dc0b1b1f1117b5779ad8 /app-i18n/libchewing/libchewing-9999.ebuild
parentapp-i18n/libchewing: Minor cleanup. (diff)
downloadgentoo-ccc64d31a21cef545ea9d82d5e18401694d093a6.tar.gz
gentoo-ccc64d31a21cef545ea9d82d5e18401694d093a6.tar.bz2
gentoo-ccc64d31a21cef545ea9d82d5e18401694d093a6.zip
app-i18n/libchewing: Add live ebuild.
Diffstat (limited to 'app-i18n/libchewing/libchewing-9999.ebuild')
-rw-r--r--app-i18n/libchewing/libchewing-9999.ebuild52
1 files changed, 52 insertions, 0 deletions
diff --git a/app-i18n/libchewing/libchewing-9999.ebuild b/app-i18n/libchewing/libchewing-9999.ebuild
new file mode 100644
index 000000000000..3dbd6c51e6fe
--- /dev/null
+++ b/app-i18n/libchewing/libchewing-9999.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+if [[ "${PV}" == "9999" ]]; then
+ inherit autotools git-r3
+
+ EGIT_REPO_URI="https://github.com/chewing/libchewing"
+fi
+
+DESCRIPTION="Intelligent phonetic (Zhuyin/Bopomofo) input method library"
+HOMEPAGE="http://chewing.im/ https://github.com/chewing/libchewing"
+if [[ "${PV}" == "9999" ]]; then
+ SRC_URI=""
+else
+ SRC_URI="https://github.com/chewing/${PN}/releases/download/v${PV}/${P}.tar.bz2"
+fi
+
+LICENSE="LGPL-2.1"
+SLOT="0/3"
+KEYWORDS=""
+IUSE="static-libs test"
+
+RDEPEND="dev-db/sqlite:3"
+DEPEND="${RDEPEND}
+ test? ( sys-libs/ncurses[unicode] )"
+
+src_prepare() {
+ default
+
+ if [[ "${PV}" == "9999" ]]; then
+ eautoreconf
+ fi
+}
+
+src_configure() {
+ # libchewing.a is required for building of tests.
+ econf \
+ --with-sqlite3 \
+ $(if use static-libs || use test; then echo --enable-static; else echo --disable-static; fi)
+}
+
+src_test() {
+ emake -j1 check
+}
+
+src_install() {
+ default
+ find "${D}" -name "*.la" -delete || die
+ use static-libs || find "${D}" -name "*.a" -delete || die
+}