summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <Arfrever@Apache.Org>2019-09-28 02:17:48 +0000
committerMike Gilbert <floppym@gentoo.org>2019-09-28 22:56:13 -0400
commit5f216ac5a93a89127bb5d32c8f5bc55f46dcd347 (patch)
treef9ce75a87c4d8b6bc788b0c112eb1091e39d5753 /app-i18n/libkkc
parentdev-libs/marisa: Add live ebuild. (diff)
downloadgentoo-5f216ac5a93a89127bb5d32c8f5bc55f46dcd347.tar.gz
gentoo-5f216ac5a93a89127bb5d32c8f5bc55f46dcd347.tar.bz2
gentoo-5f216ac5a93a89127bb5d32c8f5bc55f46dcd347.zip
app-i18n/libkkc: Version bump (0.3.6_pre20190809104047). Support Python 3.
Fixes: https://bugs.gentoo.org/695004 Signed-off-by: Arfrever Frehtes Taifersar Arahesis <Arfrever@Apache.Org> Signed-off-by: Mike Gilbert <floppym@gentoo.org>
Diffstat (limited to 'app-i18n/libkkc')
-rw-r--r--app-i18n/libkkc/Manifest1
-rw-r--r--app-i18n/libkkc/libkkc-0.3.6_pre20190809104047.ebuild67
2 files changed, 68 insertions, 0 deletions
diff --git a/app-i18n/libkkc/Manifest b/app-i18n/libkkc/Manifest
index edbfdd2a30ac..be3971ae010d 100644
--- a/app-i18n/libkkc/Manifest
+++ b/app-i18n/libkkc/Manifest
@@ -1 +1,2 @@
DIST libkkc-0.3.5.tar.gz 1424282 BLAKE2B 5c1664f85b15e4f7b82d07c21ee29b82bea0d8f534b2f866c9604e38b5578b323c3252ae76a325ec269d82c972c9155bb42ca9c765bc47e13825edabfd974ca5 SHA512 f611c3104a22ad38af29746870849d8937b6af2a7fee0952cc25f36ef845b5617a192df7ca63ff2a507384f7a6a13c9c1b4fa3b9a34f3f041bee8793d04b9236
+DIST libkkc-0.3.6_pre20190809104047.tar.gz 389976 BLAKE2B 03c43384f4f1f0e48a3eec2afb9f90a39e42469439a7dbc06692e020d83b8362f19c41ea8960cd5147edca04dcf67be5e74315f494dd017a6ce018f217b6a5a7 SHA512 87c5294900b29e4b2225c24ee744c619691a5f25edc453c2ece44133695a8d0e1a1a07bb5a00d615cc95057ae5b451c845c7ce476df555e025097c38aff87a69
diff --git a/app-i18n/libkkc/libkkc-0.3.6_pre20190809104047.ebuild b/app-i18n/libkkc/libkkc-0.3.6_pre20190809104047.ebuild
new file mode 100644
index 000000000000..3f920501d615
--- /dev/null
+++ b/app-i18n/libkkc/libkkc-0.3.6_pre20190809104047.ebuild
@@ -0,0 +1,67 @@
+# Copyright 2013-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+PYTHON_COMPAT=(python{3_6,3_7})
+
+inherit autotools python-any-r1 vala
+
+if [[ "${PV}" == "9999" ]]; then
+ inherit git-r3
+
+ EGIT_REPO_URI="https://github.com/ueno/libkkc"
+elif [[ "${PV}" == *_pre* ]]; then
+ LIBKKC_GIT_REVISION="b2e5a152980ee627c39ca8a49082e6df7694b8fc"
+fi
+
+DESCRIPTION="Japanese Kana Kanji conversion input method library"
+HOMEPAGE="https://github.com/ueno/libkkc"
+if [[ "${PV}" == "9999" ]]; then
+ SRC_URI=""
+elif [[ "${PV}" == *_pre* ]]; then
+ SRC_URI="https://github.com/ueno/${PN}/archive/${LIBKKC_GIT_REVISION}.tar.gz -> ${P}.tar.gz"
+else
+ SRC_URI="https://github.com/ueno/${PN}/releases/download/v${PV}/${P}.tar.gz"
+fi
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="nls static-libs"
+
+BDEPEND="$(python_gen_any_dep 'dev-libs/marisa[python,${PYTHON_USEDEP}]')
+ $(vala_depend)
+ dev-libs/gobject-introspection
+ virtual/pkgconfig
+ nls? ( sys-devel/gettext )"
+DEPEND="dev-libs/glib:2
+ dev-libs/json-glib
+ dev-libs/libgee:0.8
+ dev-libs/marisa
+ nls? ( virtual/libintl )"
+RDEPEND="${DEPEND}"
+
+if [[ "${PV}" == *_pre* ]]; then
+ S="${WORKDIR}/libkkc-${LIBKKC_GIT_REVISION}"
+fi
+
+python_check_deps() {
+ has_version -b "dev-libs/marisa[python,${PYTHON_USEDEP}]"
+}
+
+src_prepare() {
+ default
+ eautoreconf
+ vala_src_prepare
+}
+
+src_configure() {
+ econf \
+ $(use_enable nls) \
+ $(use_enable static-libs static)
+}
+
+src_install() {
+ default
+ find "${D}" -name "*.la" -type f -delete || die
+}