summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAkinori Hattori <hattya@gentoo.org>2017-07-01 23:51:21 +0900
committerAkinori Hattori <hattya@gentoo.org>2017-07-01 23:51:21 +0900
commite8cbbec46e044a2e42965168dcf200148724df61 (patch)
treeb18ca478b341479e223480a467a7c1a51dee807a /app-i18n/libskk/libskk-1.0.2.ebuild
parentapp-i18n/libskk: drop old (diff)
downloadgentoo-e8cbbec46e044a2e42965168dcf200148724df61.tar.gz
gentoo-e8cbbec46e044a2e42965168dcf200148724df61.tar.bz2
gentoo-e8cbbec46e044a2e42965168dcf200148724df61.zip
app-i18n/libskk: new upstream release
Gentoo-Bug: 608862 Package-Manager: Portage-2.3.6, Repoman-2.3.1
Diffstat (limited to 'app-i18n/libskk/libskk-1.0.2.ebuild')
-rw-r--r--app-i18n/libskk/libskk-1.0.2.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/app-i18n/libskk/libskk-1.0.2.ebuild b/app-i18n/libskk/libskk-1.0.2.ebuild
new file mode 100644
index 000000000000..c03b9f52026e
--- /dev/null
+++ b/app-i18n/libskk/libskk-1.0.2.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+inherit ltprune virtualx vala
+
+DESCRIPTION="GObject-based library to deal with Japanese kana-to-kanji conversion method"
+HOMEPAGE="https://github.com/ueno/libskk"
+SRC_URI="https://github.com/ueno/${PN}/releases/download/${PV}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+introspection nls static-libs"
+
+RDEPEND="dev-libs/glib:2
+ dev-libs/json-glib
+ dev-libs/libgee:0.8
+ introspection? ( dev-libs/gobject-introspection )
+ nls? ( virtual/libintl )"
+DEPEND="${RDEPEND}
+ $(vala_depend)
+ dev-util/intltool
+ virtual/pkgconfig
+ nls? ( sys-devel/gettext )"
+
+src_prepare() {
+ vala_src_prepare
+ default
+}
+
+src_configure() {
+ econf \
+ $(use_enable introspection) \
+ $(use_enable nls) \
+ $(use_enable static-libs static)
+}
+
+src_test() {
+ Xemake check
+}
+
+src_install() {
+ default
+ prune_libtool_files
+}