summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-i18n/libtabe/libtabe-0.2.6.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-i18n/libtabe/libtabe-0.2.6.ebuild')
-rw-r--r--app-i18n/libtabe/libtabe-0.2.6.ebuild52
1 files changed, 52 insertions, 0 deletions
diff --git a/app-i18n/libtabe/libtabe-0.2.6.ebuild b/app-i18n/libtabe/libtabe-0.2.6.ebuild
new file mode 100644
index 000000000000..c3e6de7a0d3f
--- /dev/null
+++ b/app-i18n/libtabe/libtabe-0.2.6.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit eutils libtool autotools multilib
+
+DESCRIPTION="Libtabe provides bimsphone support for xcin-2.5+"
+HOMEPAGE="http://packages.qa.debian.org/libt/libtabe.html"
+SRC_URI="mirror://debian/pool/main/libt/libtabe/${P/-/_}.orig.tar.gz
+ mirror://debian/pool/main/libt/libtabe/${P/-/_}-1.1.diff.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ppc x86"
+IUSE="debug"
+
+DEPEND=">=sys-libs/db-4.5
+ x11-libs/libX11"
+
+S=${WORKDIR}/${P}.orig
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${WORKDIR}"/${P/-/_}-1.1.diff
+ epatch "${FILESDIR}"/${P}-fabs.patch
+ rm -f configure
+ elibtoolize
+ cd script
+ eautoreconf
+ cp script/* ./
+ cp configure ../
+ cd ..
+}
+
+src_compile() {
+ myconf="--with-db-inc=/usr/include
+ --with-db-lib=/usr/$(get_libdir)
+ --with-db-bin=/usr/bin
+ --with-db-name=db
+ --enable-shared
+ --disable-static
+ $(use_enable debug)"
+
+ econf ${myconf}
+ emake -j1 || die "make failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed."
+ dodoc doc/*
+}