summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2017-12-18 19:13:06 +0100
committerManuel Rüger <mrueg@gentoo.org>2017-12-18 19:13:06 +0100
commitb82dc1f88361126a42a35ff5b6fe526c48d75497 (patch)
treee0b83b182ec26f4f719eab233eb16bc05d1ed6ca /app-i18n/man-pages-de
parentgames-engines/scummvm-tools: Removed old. (diff)
downloadgentoo-b82dc1f88361126a42a35ff5b6fe526c48d75497.tar.gz
gentoo-b82dc1f88361126a42a35ff5b6fe526c48d75497.tar.bz2
gentoo-b82dc1f88361126a42a35ff5b6fe526c48d75497.zip
app-i18n/man-pages-de: Version bump to 2.3 (on behalf of Markus Oehme)
Closes: https://bugs.gentoo.org/641064 Package-Manager: Portage-2.3.19, Repoman-2.3.6
Diffstat (limited to 'app-i18n/man-pages-de')
-rw-r--r--app-i18n/man-pages-de/Manifest1
-rw-r--r--app-i18n/man-pages-de/man-pages-de-2.3.ebuild51
2 files changed, 52 insertions, 0 deletions
diff --git a/app-i18n/man-pages-de/Manifest b/app-i18n/man-pages-de/Manifest
index 55615a1bb006..b803023a9dec 100644
--- a/app-i18n/man-pages-de/Manifest
+++ b/app-i18n/man-pages-de/Manifest
@@ -1,3 +1,4 @@
DIST manpages-de-1.15.tar.xz 1529576 BLAKE2B 600d9c186ffa46fd1db110c3889abc44bb6ccb6847ed8385c461c7fa696f5a9e8a65233d1290ae9d1e9eb26694e8769aa35983f07205a0e7e57c9b0c14c7d7bc SHA512 d1f1b9f60c4713d6be650e21b7664ff594dbd542b53148c00d1a2269413d39615dd76be4c4095eeb72e2598b94af134ca5d128b85d9520a1ac404364b8a53948
DIST manpages-de-1.16.tar.xz 1537396 BLAKE2B 4e54ba469f3469dcaf618eb295eef6c20a181d3a8c3ae98854d801408a5d1b8a47d193963b1da63947a2ccf9ebffc01cb140053793129df5df0a6f712e07ea1f SHA512 7e070a055804536a7777c573c2e7f7617bb305feafde70324e7a583a232f0463ee3df1b2a255b7e8cee621719db16c6b12b9d13ef4979260b085b0827b230a4f
DIST manpages-de-1.21.tar.xz 1585600 BLAKE2B f2364e0b5fc1ca8ce8f5eb7fa5987d1bc68b1f8f2c1a26240d5cabd03eb5bb094f0d63274c7208059a766498f5f20ca7ccab72a9d4847057aae3b7d6697018e7 SHA512 24cc36e8e9c2efb8cd2a0c374a3f5da96f6645a306082cc28aae5933081f7de24bac03652f690a2becd32a23a93c17ddd9029190c299dda95eeb25f49b327fac
+DIST manpages-de-2.3.tar.xz 7016372 BLAKE2B 3b89049d11bfd539e9114de38198f610145972068c9cec1da1b6398fb1d3e846b112ca0336891c1782a6fb142f397ac472ad78be0596503377318bfe65ec68d2 SHA512 abc3574c4a315d86b4fcccb25d617851c1ff43844fc7b1b92d7849a098280a96ab73d4986047fe6bb18e8f11d391182370eff9db476e0dd2021d0725b4e945eb
diff --git a/app-i18n/man-pages-de/man-pages-de-2.3.ebuild b/app-i18n/man-pages-de/man-pages-de-2.3.ebuild
new file mode 100644
index 000000000000..6698d74db09e
--- /dev/null
+++ b/app-i18n/man-pages-de/man-pages-de-2.3.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit autotools
+
+MY_P="${PN/-/}-${PV}"
+
+DESCRIPTION="A somewhat comprehensive collection of Linux german man page translations"
+HOMEPAGE="https://alioth.debian.org/projects/manpages-de/"
+SRC_URI="http://manpages-de.alioth.debian.org/downloads/${MY_P}.tar.xz"
+
+LICENSE="GPL-3+ man-pages GPL-2+ GPL-2 BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE=""
+
+RDEPEND="virtual/man"
+DEPEND="app-text/po4a"
+
+S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+ default
+
+ # sys-apps/shadow has it's own translated man-page for this
+ rm upstream/primary/man1/groups.1 po/primary/man1/groups.1.po || die
+
+ # Use the same compression as every other manpage
+ local PORTAGE_COMPRESS_LOCAL=${PORTAGE_COMPRESS-bzip2}
+ if [[ ${PORTAGE_COMPRESS+set} == "set" ]] ; then
+ PORTAGE_COMPRESS_LOCAL="#"
+ fi
+ if [[ ${PORTAGE_COMPRESS_FLAGS+set} != "set" ]] ; then
+ case ${PORTAGE_COMPRESS_LOCAL} in
+ bzip2|gzip) local PORTAGE_COMPRESS_FLAGS_LOCAL="-9"
+ ;;
+ esac
+ fi
+ sed -i -e "s/gzip --best/${PORTAGE_COMPRESS_LOCAL} ${PORTAGE_COMPRESS_FLAGS_LOCAL}/"\
+ po/Makefile.in || die
+ eautoreconf
+}
+
+src_compile() { :; }
+
+src_install() {
+ emake mandir="${ED}"/usr/share/man install
+ dodoc CHANGES.md README.md
+}