summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-i18n/mecab-skkserv/mecab-skkserv-0.03.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-i18n/mecab-skkserv/mecab-skkserv-0.03.ebuild')
-rw-r--r--app-i18n/mecab-skkserv/mecab-skkserv-0.03.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/app-i18n/mecab-skkserv/mecab-skkserv-0.03.ebuild b/app-i18n/mecab-skkserv/mecab-skkserv-0.03.ebuild
new file mode 100644
index 000000000000..b32503b8b90f
--- /dev/null
+++ b/app-i18n/mecab-skkserv/mecab-skkserv-0.03.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+inherit autotools-utils multilib
+
+DESCRIPTION="mecab-skkserv is a Kana-Kanji conversion server using MeCab"
+HOMEPAGE="http://chasen.org/~taku/software/mecab-skkserv/"
+SRC_URI="http://chasen.org/~taku/software/mecab-skkserv/${P}.tar.gz"
+
+LICENSE="GPL-2 ipadic"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=">=app-text/mecab-0.91"
+RDEPEND="${DEPEND}
+ sys-apps/xinetd"
+
+DOCS=( README NEWS AUTHORS )
+HTML_DOCS=( index.html )
+PATCHES=(
+ "${FILESDIR}"/${P}-cflags.patch
+ "${FILESDIR}"/${P}-dicrc.patch
+ )
+AUTOTOOLS_AUTORECONF=1
+AUTOTOOLS_IN_SOURCE_BUILD=1
+
+src_prepare() {
+ sed -i -e "/^dictdir/s@lib@$(get_libdir)@" Makefile.am || die
+ autotools-utils_src_prepare
+}
+
+src_install() {
+ autotools-utils_src_install
+
+ # for running skkserv from xinetd
+ insinto /etc/xinetd.d; doins "${FILESDIR}"/mecab-skkserv
+}