summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <Arfrever@Apache.Org>2019-04-18 17:29:33 +0000
committerMike Gilbert <floppym@gentoo.org>2019-04-19 12:39:06 -0400
commitf255bdc22ea3380091702991bd3cf58eb87c5186 (patch)
tree343b93e58704124240e77af2f822598721bd1f61 /app-i18n/mozc
parentapp-i18n/libpinyin: Version bump (2.3.0). (diff)
downloadgentoo-f255bdc22ea3380091702991bd3cf58eb87c5186.tar.gz
gentoo-f255bdc22ea3380091702991bd3cf58eb87c5186.tar.bz2
gentoo-f255bdc22ea3380091702991bd3cf58eb87c5186.zip
app-i18n/mozc: Use EAPI="7".
Signed-off-by: Arfrever Frehtes Taifersar Arahesis <Arfrever@Apache.Org> Signed-off-by: Mike Gilbert <floppym@gentoo.org>
Diffstat (limited to 'app-i18n/mozc')
-rw-r--r--app-i18n/mozc/mozc-2.23.2815.102.ebuild24
-rw-r--r--app-i18n/mozc/mozc-9999.ebuild24
2 files changed, 32 insertions, 16 deletions
diff --git a/app-i18n/mozc/mozc-2.23.2815.102.ebuild b/app-i18n/mozc/mozc-2.23.2815.102.ebuild
index 73baeb4cc28b..21a1291f1ea5 100644
--- a/app-i18n/mozc/mozc-2.23.2815.102.ebuild
+++ b/app-i18n/mozc/mozc-2.23.2815.102.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 2010-2019 Arfrever Frehtes Taifersar Arahesis and others
# Distributed under the terms of the GNU General Public License v2
-EAPI="6"
+EAPI="7"
PYTHON_COMPAT=(python2_7)
inherit elisp-common multiprocessing python-any-r1 toolchain-funcs
@@ -38,9 +38,19 @@ KEYWORDS="amd64 ~ppc64 x86"
IUSE="debug emacs fcitx4 +gui +handwriting-tegaki handwriting-tomoe ibus renderer test"
REQUIRED_USE="|| ( emacs fcitx4 ibus ) gui? ( ^^ ( handwriting-tegaki handwriting-tomoe ) ) !gui? ( !handwriting-tegaki !handwriting-tomoe )"
+BDEPEND="${PYTHON_DEPS}
+ >=dev-libs/protobuf-3.0.0
+ dev-util/gyp
+ dev-util/ninja
+ virtual/pkgconfig
+ emacs? ( virtual/emacs )
+ fcitx4? ( sys-devel/gettext )"
RDEPEND=">=dev-libs/protobuf-3.0.0:=
emacs? ( virtual/emacs )
- fcitx4? ( app-i18n/fcitx:4 )
+ fcitx4? (
+ app-i18n/fcitx:4
+ virtual/libintl
+ )
gui? (
app-i18n/zinnia
dev-qt/qtcore:5
@@ -61,10 +71,6 @@ RDEPEND=">=dev-libs/protobuf-3.0.0:=
x11-libs/pango
)"
DEPEND="${RDEPEND}
- ${PYTHON_DEPS}
- dev-util/gyp
- dev-util/ninja
- virtual/pkgconfig
test? (
>=dev-cpp/gtest-1.8.0
dev-libs/jsoncpp
@@ -319,5 +325,7 @@ pkg_postinst() {
}
pkg_postrm() {
- use emacs && elisp-site-regen
+ if use emacs; then
+ elisp-site-regen
+ fi
}
diff --git a/app-i18n/mozc/mozc-9999.ebuild b/app-i18n/mozc/mozc-9999.ebuild
index b51359f01fb3..7876d9ed3783 100644
--- a/app-i18n/mozc/mozc-9999.ebuild
+++ b/app-i18n/mozc/mozc-9999.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 2010-2019 Arfrever Frehtes Taifersar Arahesis and others
# Distributed under the terms of the GNU General Public License v2
-EAPI="6"
+EAPI="7"
PYTHON_COMPAT=(python2_7)
inherit elisp-common multiprocessing python-any-r1 toolchain-funcs
@@ -38,9 +38,19 @@ KEYWORDS=""
IUSE="debug emacs fcitx4 +gui +handwriting-tegaki handwriting-tomoe ibus renderer test"
REQUIRED_USE="|| ( emacs fcitx4 ibus ) gui? ( ^^ ( handwriting-tegaki handwriting-tomoe ) ) !gui? ( !handwriting-tegaki !handwriting-tomoe )"
+BDEPEND="${PYTHON_DEPS}
+ >=dev-libs/protobuf-3.0.0
+ dev-util/gyp
+ dev-util/ninja
+ virtual/pkgconfig
+ emacs? ( virtual/emacs )
+ fcitx4? ( sys-devel/gettext )"
RDEPEND=">=dev-libs/protobuf-3.0.0:=
emacs? ( virtual/emacs )
- fcitx4? ( app-i18n/fcitx:4 )
+ fcitx4? (
+ app-i18n/fcitx:4
+ virtual/libintl
+ )
gui? (
app-i18n/zinnia
dev-qt/qtcore:5
@@ -61,10 +71,6 @@ RDEPEND=">=dev-libs/protobuf-3.0.0:=
x11-libs/pango
)"
DEPEND="${RDEPEND}
- ${PYTHON_DEPS}
- dev-util/gyp
- dev-util/ninja
- virtual/pkgconfig
test? (
>=dev-cpp/gtest-1.8.0
dev-libs/jsoncpp
@@ -318,5 +324,7 @@ pkg_postinst() {
}
pkg_postrm() {
- use emacs && elisp-site-regen
+ if use emacs; then
+ elisp-site-regen
+ fi
}