summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-i18n/poedit
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-i18n/poedit')
-rw-r--r--app-i18n/poedit/Manifest2
-rw-r--r--app-i18n/poedit/files/poedit-1.5.5-wx28.patch22
-rw-r--r--app-i18n/poedit/metadata.xml8
-rw-r--r--app-i18n/poedit/poedit-1.5.5.ebuild47
-rw-r--r--app-i18n/poedit/poedit-1.8.3.ebuild71
5 files changed, 150 insertions, 0 deletions
diff --git a/app-i18n/poedit/Manifest b/app-i18n/poedit/Manifest
new file mode 100644
index 000000000000..94b4eeeff530
--- /dev/null
+++ b/app-i18n/poedit/Manifest
@@ -0,0 +1,2 @@
+DIST poedit-1.5.5.tar.gz 2594758 SHA256 3c94c9825c11a2d1ce10e083ad246e8625469f358da4a5a2f6210170b970f949 SHA512 a3524e27681dbf97babef7bf3ec56d6b7cd736370f8ed86b53c717a5a2eb36245f9ed89fcd28b57bd4d6f5ff5fb98d6c1615baae0bf10be720dcfdafa57ad4f4 WHIRLPOOL 893795acc85183cede0313b9220179cafa17a92033e8472e48454475f4ecdf51a014dc7123e9396a38a98217c43666919e7a1dadf68ab2f401b920071cec3d23
+DIST poedit-1.8.3.tar.gz 2319253 SHA256 2a73c659506c31eac142ad5b070a2370a797f3e81813c915bdd75fac2dd21ec1 SHA512 c09faf18c9e58b2f4547e47d22a2237589eb4663985d0d3411e6f83691c34d075bff188fc14a9e245efe89d976377956d604c7f09d0329ddcd70383243f0f6b0 WHIRLPOOL 31b324c4c5b731836865c7bd464003b38406bf114f39354e9c6cb2bcfb65d5a3dead3e05ba780d2f0e13d504368d40e365f6372b6c9d5493814e063dd77a0bdf
diff --git a/app-i18n/poedit/files/poedit-1.5.5-wx28.patch b/app-i18n/poedit/files/poedit-1.5.5-wx28.patch
new file mode 100644
index 000000000000..f10c731c597a
--- /dev/null
+++ b/app-i18n/poedit/files/poedit-1.5.5-wx28.patch
@@ -0,0 +1,22 @@
+catalog.cpp:1155:20: error: 'class wxCharBuffer' has no member named 'length'
+
+http://www.poedit.net/trac/ticket/513
+
+
+--- a/src/catalog.cpp
++++ b/src/catalog.cpp
+@@ -1151,8 +1151,13 @@ inline bool CanEncodeStringToCharset(const wxString& s, wxMBConv& conv)
+ {
+ if (s.empty())
+ return true;
+- wxCharBuffer converted(s.mb_str(conv));
++ const wxCharBuffer converted(s.mb_str(conv));
++#if wxCHECK_VERSION(2,9,0)
+ if ( converted.length() == 0 )
++#else
++ const char *cs = (const char*)converted;
++ if ( cs == NULL || strlen(cs) == 0 )
++#endif
+ return false;
+ return true;
+ }
diff --git a/app-i18n/poedit/metadata.xml b/app-i18n/poedit/metadata.xml
new file mode 100644
index 000000000000..3d00b413e81e
--- /dev/null
+++ b/app-i18n/poedit/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>wxwidgets</herd>
+ <upstream>
+ <remote-id type="github">vslavik/poedit</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/app-i18n/poedit/poedit-1.5.5.ebuild b/app-i18n/poedit/poedit-1.5.5.ebuild
new file mode 100644
index 000000000000..44438611fd6e
--- /dev/null
+++ b/app-i18n/poedit/poedit-1.5.5.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+WX_GTK_VER=2.8
+
+inherit eutils fdo-mime flag-o-matic wxwidgets
+
+DESCRIPTION="Cross-platform gettext catalogs (.po files) editor"
+HOMEPAGE="http://poedit.sourceforge.net/"
+SRC_URI="mirror://sourceforge/poedit/${P}.tar.gz"
+
+LICENSE="MIT CC-BY-2.5 CC-BY-SA-2.5"
+SLOT="0"
+KEYWORDS="amd64 hppa ppc sparc x86"
+IUSE="spell"
+
+RDEPEND="dev-libs/boost
+ >=sys-libs/db-4.7
+ x11-libs/wxGTK:2.8[X]
+ spell? ( app-text/gtkspell:2 )"
+
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-wx28.patch
+}
+
+src_configure() {
+ append-flags -fno-strict-aliasing
+ econf $(use_enable spell spellchecking)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ dodoc AUTHORS NEWS README TODO
+}
+
+pkg_postinst() {
+ fdo-mime_desktop_database_update
+}
+
+pkg_postrm() {
+ fdo-mime_desktop_database_update
+}
diff --git a/app-i18n/poedit/poedit-1.8.3.ebuild b/app-i18n/poedit/poedit-1.8.3.ebuild
new file mode 100644
index 000000000000..a66639042358
--- /dev/null
+++ b/app-i18n/poedit/poedit-1.8.3.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+WX_GTK_VER=3.0
+
+PLOCALES="af am an ar ast az be@latin be bg bn br bs ca ca@valencia ckb co cs da de el en_GB eo es et eu fa fi fr fur fy_NL ga gl he hi hr hu id is it ja ka kk ko ku ky lt lv mk mn mr ms nb ne nl nn oc pa pl pt_BR pt_PT ro ru sk sl sq sr sv ta tg th tr tt ug uk ur uz vi wa zh_CN zh_TW"
+
+inherit eutils fdo-mime flag-o-matic gnome2-utils l10n wxwidgets
+
+DESCRIPTION="GUI editor for gettext translations files"
+HOMEPAGE="https://poedit.net"
+SRC_URI="https://github.com/vslavik/${PN}/releases/download/v${PV}-oss/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc64 ~x86"
+IUSE=""
+
+# db/expat req for legacytm - remove in later version
+RDEPEND="
+ app-text/gtkspell:2
+ dev-cpp/lucene++
+ dev-libs/boost:=[nls]
+ dev-libs/expat
+ dev-libs/icu:=
+ || (
+ =sys-libs/db-5*:=[cxx]
+ =sys-libs/db-4*:=[cxx]
+ )
+ x11-libs/gtk+:2
+ x11-libs/wxGTK:${WX_GTK_VER}[X]
+ "
+
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_prepare() {
+ my_rm_loc() {
+ sed -i -e "/^POEDIT_LINGUAS = /s: ${1}::" locales/Makefile.in || die
+ rm "locales/${1}.mo" || die
+ }
+ l10n_find_plocales_changes 'locales' '' '.mo'
+ l10n_for_each_disabled_locale_do my_rm_loc
+
+ append-flags -Wno-deprecated-declarations
+}
+
+src_configure() {
+ econf --without-cpprest --without-cld2
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ dodoc AUTHORS NEWS README
+}
+
+pkg_preinst() {
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ fdo-mime_desktop_database_update
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ fdo-mime_desktop_database_update
+ gnome2_icon_cache_update
+}