summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-i18n/scim
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-i18n/scim')
-rw-r--r--app-i18n/scim/Manifest1
-rw-r--r--app-i18n/scim/files/xinput-scim9
-rw-r--r--app-i18n/scim/metadata.xml11
-rw-r--r--app-i18n/scim/scim-1.4.14.ebuild106
4 files changed, 127 insertions, 0 deletions
diff --git a/app-i18n/scim/Manifest b/app-i18n/scim/Manifest
new file mode 100644
index 000000000000..0b805e4d4396
--- /dev/null
+++ b/app-i18n/scim/Manifest
@@ -0,0 +1 @@
+DIST scim-1.4.14.tar.gz 1519287 SHA256 e91e4cfed92f3e19d229f702eda03038b3f9a0ce6c4e625b0be51134c19b7678 SHA512 00fe7a1b40b69aae123c0a1e67eb3744ad1e6b1e66726bb011a7426bd28012c52b346c62f08c7ecf0977ac3e88ee416337c9fa89b39142d5eea338d99641f5df WHIRLPOOL cb32326b30ff17ca4815267898de715e50893e77c28a48c55cf708f818fff4aea9e2114f982302c0fd6fd4e1fc45f2ca8490603db0de49ed4159914e1edd516d
diff --git a/app-i18n/scim/files/xinput-scim b/app-i18n/scim/files/xinput-scim
new file mode 100644
index 000000000000..1d2ef452cbc6
--- /dev/null
+++ b/app-i18n/scim/files/xinput-scim
@@ -0,0 +1,9 @@
+XIM=SCIM
+XIM_PROGRAM="@EPREFIX@/usr/bin/scim"
+XIM_ARGS="-d --no-socket"
+GTK_IM_MODULE=scim
+QT_IM_MODULE=scim
+PREFERENCE_PROGRAM="@EPREFIX@/usr/bin/scim-setup"
+SHORT_DESC="SCIM"
+LONG_DESC="Smart Common Input Method platform"
+ICON=scim-setup
diff --git a/app-i18n/scim/metadata.xml b/app-i18n/scim/metadata.xml
new file mode 100644
index 000000000000..ac9610b941e2
--- /dev/null
+++ b/app-i18n/scim/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>cjk</herd>
+ <use>
+ <flag name="gtk3">Enable support for <pkg>x11-libs/gtk+</pkg>:3</flag>
+ </use>
+ <upstream>
+ <remote-id type="sourceforge">scim</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/app-i18n/scim/scim-1.4.14.ebuild b/app-i18n/scim/scim-1.4.14.ebuild
new file mode 100644
index 000000000000..ef5f757465dc
--- /dev/null
+++ b/app-i18n/scim/scim-1.4.14.ebuild
@@ -0,0 +1,106 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="4"
+inherit eutils flag-o-matic multilib gnome2-utils autotools-utils
+
+DESCRIPTION="Smart Common Input Method (SCIM) is an Input Method (IM) development platform"
+HOMEPAGE="http://www.scim-im.org/"
+SRC_URI="mirror://sourceforge/scim/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ppc ppc64 sparc x86 ~x86-fbsd"
+IUSE="doc gtk3"
+
+RDEPEND="x11-libs/libX11
+ dev-libs/glib:2
+ gtk3? ( x11-libs/gtk+:3 )
+ !gtk3? ( x11-libs/gtk+:2 )
+ >=dev-libs/atk-1
+ >=x11-libs/pango-1
+ !app-i18n/scim-cvs"
+DEPEND="${RDEPEND}
+ doc? ( app-doc/doxygen
+ >=app-text/docbook-xsl-stylesheets-1.73.1 )
+ dev-lang/perl
+ virtual/pkgconfig
+ >=dev-util/intltool-0.33
+ sys-devel/libtool"
+AUTOTOOLS_IN_SOURCE_BUILD=1
+DOCS=(
+ README
+ AUTHORS
+ ChangeLog
+ docs/developers
+ docs/scim.cfg
+)
+
+src_configure() {
+ local gtk_version
+ if use gtk3; then
+ gtk_version="--with-gtk-version=3"
+ else
+ gtk_version="--with-gtk-version=2"
+ fi
+
+ # bug #83625
+ filter-flags -fvisibility-inlines-hidden -fvisibility=hidden
+ local myeconfargs=(
+ $(use_with doc doxygen)
+ --enable-ld-version-script
+ $gtk_version
+ )
+ autotools-utils_src_configure
+}
+
+src_compile() {
+ autotools-utils_src_compile
+ use doc && emake docs
+}
+
+src_install() {
+ use doc && HTML_DOCS=("${AUTOTOOLS_BUILD_DIR}/docs/html/")
+ autotools-utils_src_install
+
+ sed -e "s:@EPREFIX@:${EPREFIX}:" "${FILESDIR}/xinput-${PN}" > "${T}/${PN}.conf" || die
+ insinto /etc/X11/xinit/xinput.d
+ doins "${T}/${PN}.conf"
+}
+
+pkg_postinst() {
+ elog
+ elog "To use SCIM with both GTK2 and XIM, you should use the following"
+ elog "in your user startup scripts such as .gnomerc or .xinitrc:"
+ elog
+ elog "LANG='your_language' scim -d"
+ elog "export XMODIFIERS=@im=SCIM"
+ elog "export GTK_IM_MODULE=\"scim\""
+ elog "export QT_IM_MODULE=\"scim\""
+ elog
+ elog "where 'your_language' can be zh_CN, zh_TW, ja_JP.eucJP or any other"
+ elog "UTF-8 locale such as en_US.UTF-8 or ja_JP.UTF-8"
+ elog
+ elog "To use Chinese input methods:"
+ elog " # emerge app-i18n/scim-tables app-i18n/scim-pinyin"
+ elog "To use Korean input methods:"
+ elog " # emerge app-i18n/scim-hangul"
+ elog "To use Japanese input methods:"
+ elog " # emerge app-i18n/scim-anthy"
+ elog "To use various input methods (more than 30 languages):"
+ elog " # emerge app-i18n/scim-m17n"
+ elog
+ elog "Please modify ${EPREFIX}/etc/scim/global and add your UTF-8 locale to"
+ elog "/SupportedUnicodeLocales entry."
+ elog
+ ewarn
+ ewarn "If you upgraded from scim-1.2.x or scim-1.0.x, you should remerge all SCIM modules."
+ ewarn
+
+ gnome2_query_immodules_gtk2
+}
+
+pkg_postrm() {
+ gnome2_query_immodules_gtk2
+}