summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAkinori Hattori <hattya@gentoo.org>2018-05-07 22:05:25 +0900
committerAkinori Hattori <hattya@gentoo.org>2018-05-07 22:06:45 +0900
commitbaab2e6d3a4d041fc2c51975a7255713d21e2fff (patch)
tree5560036277349987008b178e855da058fab0e169 /app-i18n/skk-jisyo/skk-jisyo-201805.ebuild
parentmedia-gfx/inkscape: Use pkg-config to find freetype (diff)
downloadgentoo-baab2e6d3a4d041fc2c51975a7255713d21e2fff.tar.gz
gentoo-baab2e6d3a4d041fc2c51975a7255713d21e2fff.tar.bz2
gentoo-baab2e6d3a4d041fc2c51975a7255713d21e2fff.zip
app-i18n/skk-jisyo: new snapshot
Package-Manager: Portage-2.3.24, Repoman-2.3.6
Diffstat (limited to 'app-i18n/skk-jisyo/skk-jisyo-201805.ebuild')
-rw-r--r--app-i18n/skk-jisyo/skk-jisyo-201805.ebuild66
1 files changed, 66 insertions, 0 deletions
diff --git a/app-i18n/skk-jisyo/skk-jisyo-201805.ebuild b/app-i18n/skk-jisyo/skk-jisyo-201805.ebuild
new file mode 100644
index 000000000000..097ef29ed4cb
--- /dev/null
+++ b/app-i18n/skk-jisyo/skk-jisyo-201805.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+MY_PN=${PN^^}
+
+DESCRIPTION="Jisyo (dictionary) files for the SKK Japanese-input software"
+HOMEPAGE="http://openlab.ring.gr.jp/skk/dic.html"
+SRC_URI="mirror://gentoo/${P}.tar.xz
+ https://dev.gentoo.org/~hattya/distfiles/${P}.tar.xz"
+
+LICENSE="GPL-2 freedist public-domain"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~sparc-solaris"
+IUSE="cdb"
+
+DEPEND="virtual/awk
+ cdb? (
+ || (
+ dev-db/tinycdb
+ dev-db/cdb
+ )
+ )"
+RDEPEND=""
+
+DOCS=( ChangeLog{,.{1..3}} READMEs/committers.txt edict_doc.txt zipcode/README.ja )
+
+src_prepare() {
+ rm -f ${MY_PN}.{wrong*,noregist,not_wrong,hukugougo,notes,requested,pubdic+}
+
+ default
+}
+
+cdb_make() {
+ cdbmake "${1}" "${1}.tmp"
+}
+
+tinycdb_make() {
+ cdb -c "${1}"
+}
+
+src_compile() {
+ if use cdb; then
+ local cdbmake=cdb_make f
+ if has_version dev-db/tinycdb; then
+ cdbmake=tinycdb_make
+ fi
+ for f in {,zipcode/}${MY_PN}.*; do
+ LC_ALL=C awk '
+ /^[^;]/ {
+ s = substr($0, index($0, " ") + 1)
+ print "+" length($1) "," length(s) ":" $1 "->" s
+ }
+ END {
+ print ""
+ }
+ ' ${f} | ${cdbmake} ${f}.cdb || die
+ done
+ fi
+}
+
+src_install() {
+ insinto /usr/share/skk
+ doins {,zipcode/}${MY_PN}.*
+}