summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAkinori Hattori <hattya@gentoo.org>2020-08-20 22:46:38 +0900
committerAkinori Hattori <hattya@gentoo.org>2020-08-20 22:46:38 +0900
commitcc69d4a1a2d2b6dd8006b39f03fc3c9001f4c24a (patch)
treec2e4f64364fdb30660c0abe68bf58d179976c5aa /app-i18n/skkfep/skkfep-0.87-r1.ebuild
parentapp-emacs/ddskk: fix build with USE=-ruby (diff)
downloadgentoo-cc69d4a1a2d2b6dd8006b39f03fc3c9001f4c24a.tar.gz
gentoo-cc69d4a1a2d2b6dd8006b39f03fc3c9001f4c24a.tar.bz2
gentoo-cc69d4a1a2d2b6dd8006b39f03fc3c9001f4c24a.zip
app-i18n/skkfep: fix build with Clang
Closes: https://bugs.gentoo.org/729276 Package-Manager: Portage-2.3.103, Repoman-2.3.23 Signed-off-by: Akinori Hattori <hattya@gentoo.org>
Diffstat (limited to 'app-i18n/skkfep/skkfep-0.87-r1.ebuild')
-rw-r--r--app-i18n/skkfep/skkfep-0.87-r1.ebuild9
1 files changed, 7 insertions, 2 deletions
diff --git a/app-i18n/skkfep/skkfep-0.87-r1.ebuild b/app-i18n/skkfep/skkfep-0.87-r1.ebuild
index 3a217647e69b..468bfc2ab5e5 100644
--- a/app-i18n/skkfep/skkfep-0.87-r1.ebuild
+++ b/app-i18n/skkfep/skkfep-0.87-r1.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI="6"
-inherit toolchain-funcs
+inherit flag-o-matic toolchain-funcs
DESCRIPTION="A SKK-like Japanese input method for console"
HOMEPAGE="http://aitoweb.world.coocan.jp/soft.html"
@@ -32,6 +32,11 @@ src_prepare() {
sed -i "/SYSTEM_DIC_NAME/a#define SYSTEM_DIC_NAME \"${EPREFIX}/usr/share/skk/SKK-JISYO.L\"" config.h
default
+ # written in K&R C
+ append-flags \
+ -Wno-implicit-function-declaration \
+ -Wno-implicit-int \
+ -Wno-return-type
}
src_compile() {