summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-i18n/sunpinyin-data/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-i18n/sunpinyin-data/files')
-rw-r--r--app-i18n/sunpinyin-data/files/SLM-inst.mk62
1 files changed, 62 insertions, 0 deletions
diff --git a/app-i18n/sunpinyin-data/files/SLM-inst.mk b/app-i18n/sunpinyin-data/files/SLM-inst.mk
new file mode 100644
index 000000000000..9216a941ad1c
--- /dev/null
+++ b/app-i18n/sunpinyin-data/files/SLM-inst.mk
@@ -0,0 +1,62 @@
+#!/usr/bin/make -f
+# -*- mode: makefile; indent-tabs-mode: t -*- vim:noet:ts=4
+# Sample Makefile for lexicon generation and installation.
+
+# Little endian platforms: alpha amd64 arm hurd-i386 i386 ia64 mipsel sh3 sh4
+# Big endian platforms: hppa m68k mips powerpc ppc64 sparc s390
+ifndef ENDIANNESS
+ ENDIANNESS = le
+endif
+
+DICT_FILE = dict.utf8
+
+SLM_TARGET = lm_sc
+TSLM2_TEXT_FILE = ${SLM_TARGET}.t2g.arpa
+TSLM2_ORIG_FILE = ${SLM_TARGET}.t2g.orig
+TSLM2_DIST_FILE = ${SLM_TARGET}.t2g
+TSLM3_TEXT_FILE = ${SLM_TARGET}.t3g.arpa
+TSLM3_ORIG_FILE = ${SLM_TARGET}.t3g.orig
+TSLM3_DIST_FILE = ${SLM_TARGET}.t3g
+
+PYTRIE_FILE = pydict_sc.bin
+PYTRIE_LOG_FILE = pydict_sc.log
+
+SYSTEM_DATA_DIR = ${DESTDIR}/usr/share/sunpinyin
+
+all: slm3_dist
+install: slm3_install
+
+tslm2_orig: ${TSLM2_ORIG_FILE}
+${TSLM2_ORIG_FILE}: ${DICT_FILE} ${TSLM2_TEXT_FILE}
+ tslmpack ${TSLM2_TEXT_FILE} ${DICT_FILE} $@
+
+tslm2_dist: ${TSLM2_DIST_FILE}
+${TSLM2_DIST_FILE}: ${TSLM2_ORIG_FILE}
+ tslmendian -e ${ENDIANNESS} -i $^ -o $@
+
+lexicon2: ${DICT_FILE} ${TSLM2_ORIG_FILE}
+ genpyt -e ${ENDIANNESS} -i ${DICT_FILE} -s ${TSLM2_ORIG_FILE} \
+ -l ${PYTRIE_LOG_FILE} -o ${PYTRIE_FILE}
+
+tslm3_orig: ${TSLM3_ORIG_FILE}
+${TSLM3_ORIG_FILE}: ${DICT_FILE} ${TSLM3_TEXT_FILE}
+ tslmpack ${TSLM3_TEXT_FILE} ${DICT_FILE} $@
+
+tslm3_dist: ${TSLM3_DIST_FILE}
+${TSLM3_DIST_FILE}: ${TSLM3_ORIG_FILE}
+ tslmendian -e ${ENDIANNESS} -i $^ -o $@
+
+lexicon3: ${DICT_FILE} ${TSLM3_ORIG_FILE}
+ genpyt -e ${ENDIANNESS} -i ${DICT_FILE} -s ${TSLM3_ORIG_FILE} \
+ -l ${PYTRIE_LOG_FILE} -o ${PYTRIE_FILE}
+
+slm2_dist: ${TSLM2_DIST_FILE} lexicon2
+slm2_install: ${TSLM2_DIST_FILE} ${PYTRIE_FILE}
+ install -d ${SYSTEM_DATA_DIR}
+ install -Dm644 $^ ${SYSTEM_DATA_DIR}
+
+slm3_dist: ${TSLM3_DIST_FILE} lexicon3
+slm3_install: ${TSLM3_DIST_FILE} ${PYTRIE_FILE}
+ install -d ${SYSTEM_DATA_DIR}
+ install -Dm644 $^ ${SYSTEM_DATA_DIR}
+