summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFerenc Erki <erkiferenc@gmail.com>2019-04-10 20:38:52 +0200
committerMichał Górny <mgorny@gentoo.org>2019-04-22 09:58:34 +0200
commit835081c18ab3835755188fb9bdd1ebb6a1aa8133 (patch)
tree0243bca6b35ba4e764e8f1cd272b228889cef901 /app-i18n/translate-shell/translate-shell-0.9.6.10.ebuild
parentapp-misc/freeplane: Remove last-rited pkg (diff)
downloadgentoo-835081c18ab3835755188fb9bdd1ebb6a1aa8133.tar.gz
gentoo-835081c18ab3835755188fb9bdd1ebb6a1aa8133.tar.bz2
gentoo-835081c18ab3835755188fb9bdd1ebb6a1aa8133.zip
app-i18n/translate-shell: version bump to 0.9.6.10
Fixing dependencies and license, as well as sorting USE flags. Closes: https://bugs.gentoo.org/680310 Closes: https://bugs.gentoo.org/684048 Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Ferenc Erki <erkiferenc@gmail.com> Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'app-i18n/translate-shell/translate-shell-0.9.6.10.ebuild')
-rw-r--r--app-i18n/translate-shell/translate-shell-0.9.6.10.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/app-i18n/translate-shell/translate-shell-0.9.6.10.ebuild b/app-i18n/translate-shell/translate-shell-0.9.6.10.ebuild
new file mode 100644
index 000000000000..0a9dd731b1f1
--- /dev/null
+++ b/app-i18n/translate-shell/translate-shell-0.9.6.10.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Online command-line translator"
+HOMEPAGE="https://www.soimort.org/translate-shell/"
+SRC_URI="https://github.com/soimort/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Unlicense"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="+bidi +curl test tts"
+
+RDEPEND="
+ app-misc/rlwrap
+ =sys-apps/gawk-4*
+ curl? ( net-misc/curl[ssl] )
+ bidi? ( dev-libs/fribidi )
+ tts? ( || (
+ media-sound/mpg123
+ app-accessibility/espeak
+ media-video/mpv
+ media-video/mplayer
+ )
+ )"
+DEPEND="${RDEPEND}
+ test? ( virtual/emacs )
+ "
+
+src_test() {
+ emake NETWORK_ACCESS=no test
+}
+
+src_install() {
+ emake PREFIX="${D}/usr" install
+}