summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFerenc Erki <erkiferenc@gmail.com>2020-05-18 09:56:05 +0200
committerJoonas Niilola <juippis@gentoo.org>2020-06-12 09:59:47 +0300
commit0e294c837285fff406a18693c70e18a7026bc393 (patch)
tree891bdcdfe14762844069aab40a9d8375b7054f45 /app-i18n/translate-shell/translate-shell-0.9.6.12.ebuild
parentdev-python/click-plugins: specify BDEPEND for 1.1.1 (diff)
downloadgentoo-0e294c837285fff406a18693c70e18a7026bc393.tar.gz
gentoo-0e294c837285fff406a18693c70e18a7026bc393.tar.bz2
gentoo-0e294c837285fff406a18693c70e18a7026bc393.zip
app-i18n/translate-shell: bump version to 0.9.6.12
Signed-off-by: Ferenc Erki <erkiferenc@gmail.com> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'app-i18n/translate-shell/translate-shell-0.9.6.12.ebuild')
-rw-r--r--app-i18n/translate-shell/translate-shell-0.9.6.12.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/app-i18n/translate-shell/translate-shell-0.9.6.12.ebuild b/app-i18n/translate-shell/translate-shell-0.9.6.12.ebuild
new file mode 100644
index 000000000000..2538cb44a321
--- /dev/null
+++ b/app-i18n/translate-shell/translate-shell-0.9.6.12.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit eutils
+
+DESCRIPTION="Online command-line translator"
+HOMEPAGE="https://www.soimort.org/translate-shell/"
+SRC_URI="https://github.com/soimort/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Unlicense"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="sys-apps/gawk"
+DEPEND="${RDEPEND}
+ test? (
+ app-editors/emacs
+ app-misc/rlwrap
+ )"
+
+src_test() {
+ emake NETWORK_ACCESS=no test
+}
+
+src_install() {
+ emake PREFIX="${D}/usr" install
+}
+
+pkg_postinst() {
+ elog "You may need to install the following optional packages for full functionality:"
+ optfeature "Support all built-in translators (e.g. Apertium, Yandex)" net-misc/curl[ssl]
+ optfeature "Display text in right-to-left scripts" dev-libs/fribidi
+ optfeature "Text-to-speech functionality" media-sound/mpg123 app-accessibility/espeak media-video/mpv media-video/mplayer
+ optfeature "Interactive translation (REPL)" app-editors/emacs app-misc/rlwrap
+ optfeature "Spell checking" app-text/aspell app-text/hunspell
+}