summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthias Coppens <coppens.matthias.abc@gmail.com>2020-08-10 01:08:11 +0200
committerJoonas Niilola <juippis@gentoo.org>2020-09-06 08:55:17 +0300
commit74436838a0da53e067c2bb8a80e21f2df13244ee (patch)
tree88267e5bd74a7c881648118b31eafd2002bc0145 /app-i18n/uchardet/uchardet-9999.ebuild
parentsys-fs/simple-mtpfs: update fuse dependency slot (diff)
downloadgentoo-74436838a0da53e067c2bb8a80e21f2df13244ee.tar.gz
gentoo-74436838a0da53e067c2bb8a80e21f2df13244ee.tar.bz2
gentoo-74436838a0da53e067c2bb8a80e21f2df13244ee.zip
app-i18n/uchardet: Version bump + maintainership
+ Added version 0.0.7, patch from 0.0.6-r2 isn't needed there + EAPI 6 -> 7 + Eclass cmake-utils -> cmake + I've adopted this orphaned package Package-Manager: Portage-3.0.1, Repoman-2.3.23 Signed-off-by: Matthias Coppens <coppens.matthias.abc@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/17066 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'app-i18n/uchardet/uchardet-9999.ebuild')
-rw-r--r--app-i18n/uchardet/uchardet-9999.ebuild18
1 files changed, 12 insertions, 6 deletions
diff --git a/app-i18n/uchardet/uchardet-9999.ebuild b/app-i18n/uchardet/uchardet-9999.ebuild
index 0aef01cb3c64..031c6d829482 100644
--- a/app-i18n/uchardet/uchardet-9999.ebuild
+++ b/app-i18n/uchardet/uchardet-9999.ebuild
@@ -1,13 +1,19 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
-inherit cmake-utils git-r3
+inherit cmake
+if [ "${PV}" = 9999 ]
+then
+ inherit git-r3
+ EGIT_REPO_URI="https://anongit.freedesktop.org/git/uchardet/uchardet.git"
+else
+ SRC_URI="https://www.freedesktop.org/software/uchardet/releases/${P}.tar.xz"
+fi
DESCRIPTION="An encoding detector library"
HOMEPAGE="https://www.freedesktop.org/wiki/Software/uchardet/"
-EGIT_REPO_URI="https://anongit.freedesktop.org/git/uchardet/uchardet.git"
LICENSE="|| ( MPL-1.1 GPL-2+ LGPL-2.1+ )"
SLOT="0"
@@ -16,7 +22,7 @@ IUSE="cpu_flags_x86_sse2 static-libs test"
RESTRICT="!test? ( test )"
src_prepare() {
- cmake-utils_src_prepare
+ cmake_src_prepare
use test || cmake_comment_add_subdirectory test
}
@@ -26,5 +32,5 @@ src_configure() {
-DBUILD_STATIC=$(usex static-libs)
-DCHECK_SSE2=$(usex cpu_flags_x86_sse2)
)
- cmake-utils_src_configure
+ cmake_src_configure
}