summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-i18n/xsim/files/xsim-0.3.9.4-makefile.patch
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-i18n/xsim/files/xsim-0.3.9.4-makefile.patch')
-rw-r--r--app-i18n/xsim/files/xsim-0.3.9.4-makefile.patch153
1 files changed, 153 insertions, 0 deletions
diff --git a/app-i18n/xsim/files/xsim-0.3.9.4-makefile.patch b/app-i18n/xsim/files/xsim-0.3.9.4-makefile.patch
new file mode 100644
index 000000000000..8488d1bf135b
--- /dev/null
+++ b/app-i18n/xsim/files/xsim-0.3.9.4-makefile.patch
@@ -0,0 +1,153 @@
+diff --git a/Makefile.in b/Makefile.in
+index 6a7a195..6d2b4e6 100644
+--- a/Makefile.in
++++ b/Makefile.in
+@@ -36,7 +36,7 @@ distclean: clean
+ done && test -z "$$fail"
+
+ install-data:
+- cd plugins/IMs;make install-data
++ cd plugins/IMs;$(MAKE) install-data
+
+ uninstall:
+ @for dir in ${subdirs}; do \
+diff --git a/plugins/IMs/jianpin/Makefile.in b/plugins/IMs/jianpin/Makefile.in
+index cbbac33..50d7ef0 100644
+--- a/plugins/IMs/jianpin/Makefile.in
++++ b/plugins/IMs/jianpin/Makefile.in
+@@ -25,7 +25,7 @@ OBJS=simpleim.o simpleimc.o pyphraser.o
+ TARGET=jianpin.so
+
+ all:$(TARGET)
+- cd dict; make
++ cd dict; $(MAKE)
+
+ jianpin.so:$(OBJS)
+ $(LD_SHAREEXE) -shared -o $(TARGET) $(OBJS) $(LDFLAGS) -L$(bdblibs) $(LIBS) -l$(bdblib) $(gcclib)
+@@ -41,20 +41,20 @@ pyphraser.o:pyphraser.cpp pyphraser.h simpleimc.h $(include_path)wstring.h
+
+ clean:
+ rm -f *.o $(TARGET) core *~ *.bak
+- cd dict; make clean
++ cd dict; $(MAKE) clean
+
+ distclean:clean
+ rm -rf Makefile
+- cd dict; make distclean
++ cd dict; $(MAKE) distclean
+
+ install:all
+ $(topdir)/mkinstalldirs $(xsim_libp)
+ cp -f $(TARGET) $(xsim_libp)
+- cd dict; make install
++ cd dict; $(MAKE) install
+
+ install-data:
+- cd dict;make install-data
++ cd dict;$(MAKE) install-data
+
+ uninstall:
+ cd $(xsim_libp); rm -f $(TARGET)
+- cd dict;make uninstall
++ cd dict;$(MAKE) uninstall
+diff --git a/plugins/IMs/table/Makefile.in b/plugins/IMs/table/Makefile.in
+index a747560..cbc67bc 100644
+--- a/plugins/IMs/table/Makefile.in
++++ b/plugins/IMs/table/Makefile.in
+@@ -25,7 +25,7 @@ OBJS=tableim.o tableimc.o
+ TARGET=table.so
+
+ all:$(TARGET)
+- cd dict; make
++ cd dict; $(MAKE)
+
+ $(TARGET):$(OBJS)
+ $(LD_SHAREEXE) -shared -o $(TARGET) $(OBJS) $(LDFLAGS) -L$(bdblibs) $(LIBS) -l$(bdblib) $(gcclib)
+@@ -38,20 +38,20 @@ tableimc.o:tableimc.h tableimc.cpp $(include_path)wstring.h $(include_path)imc.h
+
+ clean:
+ rm -f *.o $(TARGET) core *~ *.bak
+- cd dict; make clean
++ cd dict; $(MAKE) clean
+
+ distclean:clean
+ rm -rf Makefile
+- cd dict; make distclean
++ cd dict; $(MAKE) distclean
+
+ install:all
+ $(topdir)/mkinstalldirs $(xsim_libp)
+ cp -f $(TARGET) $(xsim_libp)
+- cd dict; make install
++ cd dict; $(MAKE) install
+
+ install-data:
+- cd dict;make install-data
++ cd dict;$(MAKE) install-data
+
+ uninstall:
+ cd $(xsim_libp); rm -f $(TARGET)
+- cd dict; make uninstall
++ cd dict; $(MAKE) uninstall
+diff --git a/plugins/IMs/wubi/Makefile.in b/plugins/IMs/wubi/Makefile.in
+index 031f1a7..c3d0f88 100644
+--- a/plugins/IMs/wubi/Makefile.in
++++ b/plugins/IMs/wubi/Makefile.in
+@@ -25,7 +25,7 @@ OBJS=wubiim.o wubiimc.o
+ TARGET=wubi.so
+
+ all:$(TARGET)
+- cd dict; make
++ cd dict; $(MAKE)
+
+ $(TARGET):$(OBJS)
+ $(LD_SHAREEXE) -shared -o $(TARGET) $(OBJS) $(LDFLAGS) -L$(bdblibs) $(LIBS) -l$(bdblib) $(gcclib)
+@@ -38,20 +38,20 @@ wubiimc.o:wubiimc.h wubiimc.cpp $(include_path)wstring.h $(include_path)imc.h
+
+ clean:
+ rm -f *.o $(TARGET) core *~ *.bak
+- cd dict; make clean
++ cd dict; $(MAKE) clean
+
+ distclean:clean
+ rm -rf Makefile
+- cd dict; make distclean
++ cd dict; $(MAKE) distclean
+
+ install:all
+ $(topdir)/mkinstalldirs $(xsim_libp)
+ cp -f $(TARGET) $(xsim_libp)
+- cd dict; make install
++ cd dict; $(MAKE) install
+
+ install-data:
+- cd dict;make install-data
++ cd dict;$(MAKE) install-data
+
+ uninstall:
+ cd $(xsim_libp); rm -f $(TARGET)
+- cd dict; make uninstall
++ cd dict; $(MAKE) uninstall
+diff --git a/xsim/Makefile.in b/xsim/Makefile.in
+index d618a2c..bbe1599 100644
+--- a/xsim/Makefile.in
++++ b/xsim/Makefile.in
+@@ -58,15 +58,15 @@ wstring.o:wstring.h wstring.cpp
+ $(CXX) -c wstring.cpp $(CXXFLAGS) -I./IMdkit
+
+ IMdkit/libXimd.a:
+- cd IMdkit;make
++ cd IMdkit;$(MAKE)
+
+ clean:
+ rm -f *.o xsim core *~ *.bak
+- cd IMdkit; make clean
++ cd IMdkit; $(MAKE) clean
+
+ distclean:clean
+ rm -rf Makefile tags
+- cd IMdkit; make distclean
++ cd IMdkit; $(MAKE) distclean
+
+ install:all
+ $(topdir)/mkinstalldirs $(xsim_binp)