summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <Arfrever@Apache.Org>2020-09-02 01:00:00 +0000
committerMike Gilbert <floppym@gentoo.org>2020-09-02 10:23:07 -0400
commit13283ffdd7580d48a65387a3fe38b8e3ddea4d8b (patch)
tree8fb2ea9cc7ffdcf505beee82889fdcaf3b9459d1 /app-i18n/xsunpinyin
parentapp-i18n/sunpinyin: Version bump (2.0.4_pre20200306162733). (diff)
downloadgentoo-13283ffdd7580d48a65387a3fe38b8e3ddea4d8b.tar.gz
gentoo-13283ffdd7580d48a65387a3fe38b8e3ddea4d8b.tar.bz2
gentoo-13283ffdd7580d48a65387a3fe38b8e3ddea4d8b.zip
app-i18n/xsunpinyin: Version bump (2.0.4_pre20200306162733).
Bug: https://bugs.gentoo.org/695010 Bug: https://bugs.gentoo.org/695022 Signed-off-by: Arfrever Frehtes Taifersar Arahesis <Arfrever@Apache.Org> Signed-off-by: Mike Gilbert <floppym@gentoo.org>
Diffstat (limited to 'app-i18n/xsunpinyin')
-rw-r--r--app-i18n/xsunpinyin/Manifest1
-rw-r--r--app-i18n/xsunpinyin/xsunpinyin-2.0.4_pre20200306162733.ebuild74
2 files changed, 75 insertions, 0 deletions
diff --git a/app-i18n/xsunpinyin/Manifest b/app-i18n/xsunpinyin/Manifest
index 016fef2a7157..910333931280 100644
--- a/app-i18n/xsunpinyin/Manifest
+++ b/app-i18n/xsunpinyin/Manifest
@@ -1 +1,2 @@
+DIST sunpinyin-2.0.4_pre20200306162733.tar.gz 547519 BLAKE2B 6e0e4457217d7b85221cab15173f588a5c7c039208a8f6cd48ed5fb21c5b5eae2f4616d6fddbf6eff8a006193097de26c866d5385d4602f41059ee8d7e52a2d5 SHA512 e8cf73aeca8dcbc7dd6f51f034a9a0363201bc14a814800e071c987933935b0e8039aa84178a6bd1cba1c7dee4b25b2d5546e78ea683e68e8981afea48fdab33
DIST sunpinyin-3.0.0_rc1.tar.gz 547138 BLAKE2B 682e733241d690d1fef8ce452c497a894c5ab61bf5298c1f292ce3a25a681d594744db43ebd51b3e59274cce0e47a1bce15a793f2c20e2998915c3432f2a7c32 SHA512 c9d4936de5835a7f02e52c5b32bf1a42d76bf7588449aaa813f3df7ab2d72f3ca0f4e18f74a60be4860f0724b5e05cbe567c67e6f3150b0e71b23b3a9002fc5e
diff --git a/app-i18n/xsunpinyin/xsunpinyin-2.0.4_pre20200306162733.ebuild b/app-i18n/xsunpinyin/xsunpinyin-2.0.4_pre20200306162733.ebuild
new file mode 100644
index 000000000000..995dffb32e0e
--- /dev/null
+++ b/app-i18n/xsunpinyin/xsunpinyin-2.0.4_pre20200306162733.ebuild
@@ -0,0 +1,74 @@
+# Copyright 2011-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+PYTHON_COMPAT=(python{3_6,3_7,3_8})
+
+inherit python-any-r1 scons-utils toolchain-funcs
+
+MY_PN="sunpinyin"
+MY_P="${MY_PN}-${PV}"
+
+if [[ "${PV}" == "9999" ]]; then
+ inherit git-r3
+
+ EGIT_REPO_URI="https://github.com/sunpinyin/sunpinyin"
+elif [[ "${PV}" == *_pre* ]]; then
+ SUNPINYIN_GIT_REVISION="f39c195db08661e894017507842991a1ef70bedf"
+fi
+
+DESCRIPTION="Standalone XIM server for SunPinyin"
+HOMEPAGE="https://github.com/sunpinyin/sunpinyin"
+if [[ "${PV}" == "9999" ]]; then
+ SRC_URI=""
+elif [[ "${PV}" == *_pre* ]]; then
+ SRC_URI="https://github.com/sunpinyin/${MY_PN}/archive/${SUNPINYIN_GIT_REVISION}.tar.gz -> ${MY_P}.tar.gz"
+else
+ SRC_URI="https://github.com/sunpinyin/${MY_PN}/archive/v${PV/_/-}.tar.gz -> ${MY_P}.tar.gz"
+fi
+
+LICENSE="|| ( CDDL LGPL-2.1 )"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+BDEPEND="${PYTHON_DEPS}
+ virtual/pkgconfig"
+DEPEND="~app-i18n/sunpinyin-${PV}
+ dev-libs/glib:2
+ x11-libs/cairo
+ x11-libs/gdk-pixbuf:2
+ x11-libs/gtk+:2
+ x11-libs/libX11
+ x11-libs/pango"
+RDEPEND="${DEPEND}
+ app-i18n/sunpinyin-data"
+
+if [[ "${PV}" == *_pre* ]]; then
+ S="${WORKDIR}/${MY_PN}-${SUNPINYIN_GIT_REVISION}"
+elif [[ "${PV}" != "9999" ]]; then
+ S="${WORKDIR}/${MY_PN}-${PV/_/-}"
+fi
+
+src_prepare() {
+ default
+
+ # https://github.com/sunpinyin/sunpinyin/pull/101
+ sed -e "/^[[:space:]]*print /s/print \(.*\)/print(\1)/" -i wrapper/xim/SConstruct || die
+
+ # https://github.com/sunpinyin/sunpinyin/issues/110
+ sed -e "s/^\( *\)('CXX', 'CXX'),/&\n\1('AR', 'AR'),\n\1('RANLIB', 'RANLIB'),/" -i wrapper/xim/SConstruct || die
+}
+
+src_configure() {
+ tc-export AR CC CXX RANLIB
+}
+
+src_compile() {
+ escons -C wrapper/xim \
+ --prefix="${EPREFIX}/usr"
+}
+
+src_install() {
+ escons -C wrapper/xim --install-sandbox="${D}" install
+}