summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJuanjie Xi <strangemk3@gmail.com>2017-12-22 09:30:40 +0900
committerBenda Xu <heroxbd@gentoo.org>2017-12-22 14:10:12 +0900
commit2dcb5c853731bbc4a8957aa213f0ec94e7dd9634 (patch)
tree89a22f7f94a34e0156c25fab3e1347c1029108c2 /app-i18n/zhcon
parentdev-php/PHPMailer: another revision to sort out PHP extension deps. (diff)
downloadgentoo-2dcb5c853731bbc4a8957aa213f0ec94e7dd9634.tar.gz
gentoo-2dcb5c853731bbc4a8957aa213f0ec94e7dd9634.tar.bz2
gentoo-2dcb5c853731bbc4a8957aa213f0ec94e7dd9634.zip
app-i18n/zhcon: Update to EAPI-6
Remove the old EAPI-3 ebuild. Closes: https://bugs.gentoo.org/621956 Closes: https://github.com/gentoo/gentoo/pull/6595 Package-Manager: Portage-2.3.13
Diffstat (limited to 'app-i18n/zhcon')
-rw-r--r--app-i18n/zhcon/files/zhcon-0.2.6.sysconfdir.patch12
-rw-r--r--app-i18n/zhcon/zhcon-0.2.6-r3.ebuild (renamed from app-i18n/zhcon/zhcon-0.2.6-r2.ebuild)32
2 files changed, 24 insertions, 20 deletions
diff --git a/app-i18n/zhcon/files/zhcon-0.2.6.sysconfdir.patch b/app-i18n/zhcon/files/zhcon-0.2.6.sysconfdir.patch
index bc1d8713cd22..551d656dd6e2 100644
--- a/app-i18n/zhcon/files/zhcon-0.2.6.sysconfdir.patch
+++ b/app-i18n/zhcon/files/zhcon-0.2.6.sysconfdir.patch
@@ -1,6 +1,6 @@
-diff -ruN zhcon-0.2.5/src/Makefile.am /tmp/zhcon-0.2.5/src/Makefile.am
---- a/zhcon-0.2.5/src/Makefile.am 2006-06-22 12:35:01.531885552 +0800
-+++ b/zhcon-0.2.5/src/Makefile.am 2006-06-22 12:31:44.000000000 +0800
+diff -ruN /src/Makefile.am /tmp/src/Makefile.am
+--- a/src/Makefile.am 2006-06-22 12:35:01.531885552 +0800
++++ b/src/Makefile.am 2006-06-22 12:31:44.000000000 +0800
@@ -5,6 +5,8 @@
zhcon_LDADD = display/libdisplay.a
@@ -10,9 +10,9 @@ diff -ruN zhcon-0.2.5/src/Makefile.am /tmp/zhcon-0.2.5/src/Makefile.am
SUBDIRS = display
install-exec-local:
-diff -ruN zhcon-0.2.5/src/zhcon.cpp /tmp/zhcon-0.2.5/src/zhcon.cpp
---- a/zhcon-0.2.5/src/zhcon.cpp 2006-06-22 12:35:01.398905768 +0800
-+++ b/zhcon-0.2.5/src/zhcon.cpp 2006-06-22 12:32:41.000000000 +0800
+diff -ruN src/zhcon.cpp /tmp/src/zhcon.cpp
+--- a/src/zhcon.cpp 2006-06-22 12:35:01.398905768 +0800
++++ b/src/zhcon.cpp 2006-06-22 12:32:41.000000000 +0800
@@ -123,7 +123,7 @@
string cfgfile = getenv("HOME");
cfgfile += "/.zhconrc";
diff --git a/app-i18n/zhcon/zhcon-0.2.6-r2.ebuild b/app-i18n/zhcon/zhcon-0.2.6-r3.ebuild
index 65f87490e84a..f428d22d614f 100644
--- a/app-i18n/zhcon/zhcon-0.2.6-r2.ebuild
+++ b/app-i18n/zhcon/zhcon-0.2.6-r3.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI="3"
+EAPI="6"
WANT_AUTOMAKE="1.9"
inherit autotools eutils
@@ -24,16 +24,20 @@ RDEPEND="${DEPEND}"
S="${WORKDIR}/${MY_P}"
+PATCHES=(
+ "${FILESDIR}"/${P}.sysconfdir.patch
+ "${FILESDIR}"/${P}.configure.in.patch
+ "${FILESDIR}"/${P}+gcc-4.3.patch
+ "${FILESDIR}"/${P}+linux-headers-2.6.26.patch
+ "${FILESDIR}"/${P}-curses.patch
+ "${FILESDIR}"/${P}-amd64.patch
+ "${FILESDIR}"/${P}-automagic-fix.patch
+ "${FILESDIR}"/${P}.make-fix.patch
+)
+
src_prepare() {
epatch "${DISTDIR}"/zhcon-0.2.5-to-0.2.6.diff.gz
- epatch "${FILESDIR}"/${P}.sysconfdir.patch
- epatch "${FILESDIR}"/${P}.configure.in.patch
- epatch "${FILESDIR}"/${P}+gcc-4.3.patch
- epatch "${FILESDIR}"/${P}+linux-headers-2.6.26.patch
- epatch "${FILESDIR}"/${P}-curses.patch
- epatch "${FILESDIR}"/${P}-amd64.patch
- epatch "${FILESDIR}"/${P}-automagic-fix.patch
- epatch "${FILESDIR}"/${P}.make-fix.patch
+ default
for f in $(grep -lir HAVE_GGI_LIB *); do
sed -i -e "s/HAVE_GGI_LIB/HAVE_LIBGGI/" "${f}" || die "sed failed"
done
@@ -42,12 +46,12 @@ src_prepare() {
src_configure() {
econf $(use_with ggi) \
- $(use_with gpm) || die
+ $(use_with gpm)
}
src_install() {
- emake DESTDIR="${D}" install || die
+ emake DESTDIR="${D}" install
- dodoc AUTHORS ChangeLog README NEWS TODO THANKS || die
- dodoc README.BSD README.gpm README.utf8 || die
+ dodoc AUTHORS ChangeLog README NEWS TODO THANKS
+ dodoc README.BSD README.gpm README.utf8
}