summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAkinori Hattori <hattya@gentoo.org>2019-12-13 22:28:46 +0900
committerAkinori Hattori <hattya@gentoo.org>2019-12-13 22:28:46 +0900
commit0a6b403aa61a4b5ebfd6a31406ea42279b7ee4de (patch)
treec63901b77d6486ac718a71b05ce35960a9569def /app-i18n
parentwww-client/w3mmee: fix build with >=dev-libs/openssl-1.1 (diff)
downloadgentoo-0a6b403aa61a4b5ebfd6a31406ea42279b7ee4de.tar.gz
gentoo-0a6b403aa61a4b5ebfd6a31406ea42279b7ee4de.tar.bz2
gentoo-0a6b403aa61a4b5ebfd6a31406ea42279b7ee4de.zip
app-i18n/skk-jisyo: new snapshot
Package-Manager: Portage-2.3.79, Repoman-2.3.16 Signed-off-by: Akinori Hattori <hattya@gentoo.org>
Diffstat (limited to 'app-i18n')
-rw-r--r--app-i18n/skk-jisyo/Manifest1
-rw-r--r--app-i18n/skk-jisyo/skk-jisyo-201905.ebuild70
2 files changed, 71 insertions, 0 deletions
diff --git a/app-i18n/skk-jisyo/Manifest b/app-i18n/skk-jisyo/Manifest
index 9cece8ff1f6c..4e9af7381e74 100644
--- a/app-i18n/skk-jisyo/Manifest
+++ b/app-i18n/skk-jisyo/Manifest
@@ -1,2 +1,3 @@
DIST skk-jisyo-201605.tar.xz 6288104 BLAKE2B d68332a4fa0804b596fc42f3dc8231a6eebe8bddacc6e0babec6cc5992ddaadb46e8fa9af742daa30545a585428afe79eab28329ce1d37e0192b08b20d7c584e SHA512 1093d363fe571c3e3e05fa54046fc4b88cbed2fbd104838576c83694556585401c3affa0afb2ed078c6f1b06f62a7b14145b1305f6fef089f160b4073900c7a1
DIST skk-jisyo-201805.tar.xz 6133180 BLAKE2B 52408eb2f1fa5e5146fd4db55c249f80b5ede7d2ce1e7a3c11fb69507f87f86d778e25b04ce4e39dd241ea2d8000d829b34c47df991cb91f886923e330b652eb SHA512 13675502332609857b66391bdb9dc252b9f7a48814f6db10c60106b9cc3ce823df7615d77e0579d13b9d3da93dae2006cedc145d8dd80af39b9d4ecfe94373d5
+DIST skk-jisyo-201905.tar.xz 6198572 BLAKE2B a26e0be0406699424b24a8d1b004317b5d274fc02ed50ef6c4c696de8e039a6cfd7b34b292b7b7ecbdc2fee1950f6cc2a122ef457ba12f96972584560d3ac355 SHA512 db32fab5d5bf232838a3d502d4f648dde556381df9f96acec13d011274dedf5443676ce36324430dbe8cacb6a037e7bf70e72ef46b94fc6b57b9448e76aab38b
diff --git a/app-i18n/skk-jisyo/skk-jisyo-201905.ebuild b/app-i18n/skk-jisyo/skk-jisyo-201905.ebuild
new file mode 100644
index 000000000000..988c19a0a04e
--- /dev/null
+++ b/app-i18n/skk-jisyo/skk-jisyo-201905.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+MY_PN=${PN^^}
+
+DESCRIPTION="Jisyo (dictionary) files for the SKK Japanese-input software"
+HOMEPAGE="http://openlab.ring.gr.jp/skk/dic.html"
+SRC_URI="mirror://gentoo/${P}.tar.xz
+ https://dev.gentoo.org/~hattya/distfiles/${P}.tar.xz"
+
+LICENSE="GPL-2 freedist public-domain"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~sparc-solaris"
+IUSE="cdb"
+
+DEPEND="virtual/awk
+ cdb? (
+ || (
+ dev-db/tinycdb
+ dev-db/cdb
+ )
+ )"
+RDEPEND=""
+
+DOCS=( ChangeLog{,.{1..3}} committers.txt edict_doc.txt )
+
+src_prepare() {
+ rm -f ${MY_PN}.{wrong*,noregist,not_wrong,hukugougo,notes,requested,pubdic+}
+
+ default
+}
+
+cdb_make() {
+ cdbmake "${1}" "${1}.tmp"
+}
+
+tinycdb_make() {
+ cdb -c "${1}"
+}
+
+src_compile() {
+ if use cdb; then
+ local cdbmake=cdb_make f
+ if has_version dev-db/tinycdb; then
+ cdbmake=tinycdb_make
+ fi
+ for f in {,zipcode/}${MY_PN}.*; do
+ LC_ALL=C awk '
+ /^[^;]/ {
+ s = substr($0, index($0, " ") + 1)
+ print "+" length($1) "," length(s) ":" $1 "->" s
+ }
+ END {
+ print ""
+ }
+ ' ${f} | ${cdbmake} ${f}.cdb || die
+ done
+ fi
+}
+
+src_install() {
+ insinto /usr/share/skk
+ doins {,zipcode/}${MY_PN}.*
+
+ einstalldocs
+ docinto zipcode
+ dodoc zipcode/README.md
+}