summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAkinori Hattori <hattya@gentoo.org>2021-08-12 22:31:50 +0900
committerAkinori Hattori <hattya@gentoo.org>2021-08-12 22:35:45 +0900
commit1e78412547820a801f12e0ae1131225ab6777745 (patch)
tree5fd74816c79498c4a864635f0986e1194bd65f31 /app-i18n
parentsci-libs/ignition-fuel-tools: use cmake eclass (diff)
downloadgentoo-1e78412547820a801f12e0ae1131225ab6777745.tar.gz
gentoo-1e78412547820a801f12e0ae1131225ab6777745.tar.bz2
gentoo-1e78412547820a801f12e0ae1131225ab6777745.zip
app-i18n/ibus-typing-booster: new upstream release
Package-Manager: Portage-3.0.20, Repoman-3.0.2 Signed-off-by: Akinori Hattori <hattya@gentoo.org>
Diffstat (limited to 'app-i18n')
-rw-r--r--app-i18n/ibus-typing-booster/Manifest1
-rw-r--r--app-i18n/ibus-typing-booster/ibus-typing-booster-2.14.0.ebuild48
2 files changed, 49 insertions, 0 deletions
diff --git a/app-i18n/ibus-typing-booster/Manifest b/app-i18n/ibus-typing-booster/Manifest
index d96e7b1ba974..f99deaec1d59 100644
--- a/app-i18n/ibus-typing-booster/Manifest
+++ b/app-i18n/ibus-typing-booster/Manifest
@@ -1,2 +1,3 @@
DIST ibus-typing-booster-2.10.5.tar.gz 9448121 BLAKE2B 32e332df5e68a81c4f86df298389bb1fd9daf97b1f281bdc150183bd939a97021540aa81db5fa94ee3890c9b9a031a8eb75241da3716763ed6262fc5d5b3fb9d SHA512 f3bc5536874227b5482e46a097ac634a522651b3d200b33207705f5b1d87b8894dd962e19c389281fa5f32c1edbf3186dbfba12d718cbc6fa159d648bc622bf6
DIST ibus-typing-booster-2.11.5.tar.gz 9485824 BLAKE2B 41d9aa2ba310e2db725e7809a67988fa69fee117b560d945a3cd935e7b2bbc372f448a531ed4ebd2a131dc1ffe3cb7d86b7d10fdbce56a2e241157f08a84ca69 SHA512 a30c81903b3d99f23a606f7f083615283ba64a0e62ac54183327447c33f6f7212472742036634522d36776a45ac72ce7874bcada624361f930785e2823652f0c
+DIST ibus-typing-booster-2.14.0.tar.gz 10048272 BLAKE2B 638978811e6c7f4fa6607a7925aaf89636390391359c3e312a40ab759fff81066ea980995a3ec33f51dcb6fed5009d11bb90409c37b65c8f005b9769333e0cfb SHA512 5db5791e25caba4fa845c33198c20365c1e07cbbbfd6fe2d1d3145771b16031cc9baa55f950870fc11d4079ce04dac246603e45285550e856fc403342ae51676
diff --git a/app-i18n/ibus-typing-booster/ibus-typing-booster-2.14.0.ebuild b/app-i18n/ibus-typing-booster/ibus-typing-booster-2.14.0.ebuild
new file mode 100644
index 000000000000..4e8cb0ffc7f7
--- /dev/null
+++ b/app-i18n/ibus-typing-booster/ibus-typing-booster-2.14.0.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+PYTHON_COMPAT=( python3_{8,9} )
+PYTHON_REQ_USE="sqlite(+)"
+
+inherit gnome2-utils python-single-r1 xdg
+
+DESCRIPTION="Completion input method for IBus"
+HOMEPAGE="https://mike-fabian.github.io/ibus-typing-booster"
+SRC_URI="https://github.com/mike-fabian/${PN}/releases/download/${PV}/${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+RESTRICT="test"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+DEPEND="${PYTHON_DEPS}
+ dev-libs/m17n-lib
+ $(python_gen_cond_dep '
+ app-i18n/ibus[python(+),${PYTHON_USEDEP}]
+ dev-python/dbus-python[${PYTHON_USEDEP}]
+ dev-python/pyenchant[${PYTHON_USEDEP}]
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+ dev-python/pyxdg[${PYTHON_USEDEP}]
+ ')"
+RDEPEND="${DEPEND}
+ >=dev-db/m17n-db-1.7"
+BDEPEND="sys-devel/gettext
+ virtual/pkgconfig"
+
+pkg_preinst() {
+ xdg_pkg_preinst
+ gnome2_schemas_savelist
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}