summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <Arfrever@Apache.Org>2016-10-13 09:24:23 +0200
committerMike Gilbert <floppym@gentoo.org>2016-10-13 12:08:18 -0400
commit28d67befb9e7d7cc25430acc3dc50b22685872e9 (patch)
treef868b9c3b5b04eb54c84854c5b32b3697487c019 /app-i18n
parentapp-i18n/fcitx-unikey: Rename "qt4" USE flag to "macro-editor". (diff)
downloadgentoo-28d67befb9e7d7cc25430acc3dc50b22685872e9.tar.gz
gentoo-28d67befb9e7d7cc25430acc3dc50b22685872e9.tar.bz2
gentoo-28d67befb9e7d7cc25430acc3dc50b22685872e9.zip
app-i18n/fcitx-unikey: Add live ebuild.
Diffstat (limited to 'app-i18n')
-rw-r--r--app-i18n/fcitx-unikey/fcitx-unikey-9999.ebuild59
1 files changed, 59 insertions, 0 deletions
diff --git a/app-i18n/fcitx-unikey/fcitx-unikey-9999.ebuild b/app-i18n/fcitx-unikey/fcitx-unikey-9999.ebuild
new file mode 100644
index 000000000000..cb36531314ed
--- /dev/null
+++ b/app-i18n/fcitx-unikey/fcitx-unikey-9999.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="6"
+
+inherit cmake-utils gnome2-utils
+
+if [[ "${PV}" == "9999" ]]; then
+ inherit git-r3
+
+ EGIT_REPO_URI="https://github.com/fcitx/fcitx-unikey"
+fi
+
+DESCRIPTION="Vietnamese Unikey input methods for Fcitx"
+HOMEPAGE="https://fcitx-im.org/ https://github.com/fcitx/fcitx-unikey"
+if [[ "${PV}" == "9999" ]]; then
+ SRC_URI=""
+else
+ SRC_URI="https://download.fcitx-im.org/${PN}/${P}.tar.xz"
+fi
+
+LICENSE="GPL-2+ GPL-3+"
+SLOT="0"
+KEYWORDS=""
+IUSE="+macro-editor"
+
+RDEPEND=">=app-i18n/fcitx-4.2.8
+ virtual/libintl
+ macro-editor? (
+ >=app-i18n/fcitx-4.2.8[qt4]
+ dev-qt/qtcore:4
+ dev-qt/qtgui:4
+ )"
+DEPEND="${RDEPEND}
+ sys-devel/gettext
+ virtual/pkgconfig"
+
+DOCS=()
+
+src_configure() {
+ local mycmakeargs=(
+ -DENABLE_QT=$(usex macro-editor)
+ )
+
+ cmake-utils_src_configure
+}
+
+pkg_preinst() {
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}