summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAkinori Hattori <hattya@gentoo.org>2021-08-15 23:07:00 +0900
committerAkinori Hattori <hattya@gentoo.org>2021-08-15 23:07:00 +0900
commit8658b58a6def7d40886654dcf87307b9258fd138 (patch)
tree4a9cb0b5c2235b27d1ecaf3c3eea385e745eef77 /app-i18n
parentgames-strategy/warzone2100: Revbump to fix video install location (diff)
downloadgentoo-8658b58a6def7d40886654dcf87307b9258fd138.tar.gz
gentoo-8658b58a6def7d40886654dcf87307b9258fd138.tar.bz2
gentoo-8658b58a6def7d40886654dcf87307b9258fd138.zip
app-i18n/ibus-m17n: new upstream release
Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Akinori Hattori <hattya@gentoo.org>
Diffstat (limited to 'app-i18n')
-rw-r--r--app-i18n/ibus-m17n/Manifest1
-rw-r--r--app-i18n/ibus-m17n/ibus-m17n-1.4.7.ebuild45
2 files changed, 46 insertions, 0 deletions
diff --git a/app-i18n/ibus-m17n/Manifest b/app-i18n/ibus-m17n/Manifest
index aaff757784b4..362415e38f35 100644
--- a/app-i18n/ibus-m17n/Manifest
+++ b/app-i18n/ibus-m17n/Manifest
@@ -1,2 +1,3 @@
DIST ibus-m17n-1.4.5.tar.gz 493250 BLAKE2B a5fd4de169997dea78acf6273a7e44cefbc9ab4499cbee92c30f394ef7267c15fb1af42d45d227bc160150f35195477f9ec3d2534f9764bab4fa86c0fae046eb SHA512 64bed564d59b0992ebc8a931e0845f687c176e5336d7c7fbc1d575433eb276714615f8fee412a532ec2c8870e46d8d6c41636c984b666c92427dadbdc84838b5
DIST ibus-m17n-1.4.6.tar.gz 493592 BLAKE2B 1b9978277a008a4e72ffe03306d409532da7757d53cdb8bae9d6b5776b417e3b731fe432cb5f5c50f7f52d83ed9a2dd572a866111f9186ac42f5ce8afe511ad4 SHA512 d33c89735e5e6c93301a3c3985f46708e41d44b66e580b282e484a7497c0b9d2615c66931cdd7260b4a63d9e9af4d9ebbad5e23d4a3f8a7773dcab61a7600c57
+DIST ibus-m17n-1.4.7.tar.gz 493889 BLAKE2B 48a9b2ff1590d790d763014c0c9e5c08bf7ba84361a922aa71ab9cdb5b5e4c69fc5608a27c19eadc83578fdaafc3375c5bcedc1d81e2743a994d622042ffd436 SHA512 b011d4ee63a538a51f67012932d872fc2d527c6f3e5dd1642b7e70d3a32164532bc2ab69fb794eb985617b2698074af9079dac7991b5a2a30828595b129cce40
diff --git a/app-i18n/ibus-m17n/ibus-m17n-1.4.7.ebuild b/app-i18n/ibus-m17n/ibus-m17n-1.4.7.ebuild
new file mode 100644
index 000000000000..1fabfb506072
--- /dev/null
+++ b/app-i18n/ibus-m17n/ibus-m17n-1.4.7.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+inherit gnome2-utils xdg
+
+DESCRIPTION="M17N engine for IBus"
+HOMEPAGE="https://github.com/ibus/ibus/wiki"
+SRC_URI="https://github.com/ibus/${PN}/releases/download/${PV}/${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="gtk nls"
+
+DEPEND="app-i18n/ibus
+ dev-libs/m17n-lib
+ gtk? ( x11-libs/gtk+:3 )
+ nls? ( virtual/libintl )"
+RDEPEND="${DEPEND}
+ >=dev-db/m17n-db-1.7"
+BDEPEND="sys-devel/gettext
+ virtual/pkgconfig"
+
+src_configure() {
+ econf \
+ $(use_enable nls) \
+ $(use_with gtk gtk 3.0)
+}
+
+pkg_preinst() {
+ xdg_pkg_preinst
+ gnome2_schemas_savelist
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}