summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAkinori Hattori <hattya@gentoo.org>2023-04-30 14:14:31 +0900
committerAkinori Hattori <hattya@gentoo.org>2023-04-30 14:14:31 +0900
commita886a9ed89c2589c597f9c1d5a3b2167a663ed76 (patch)
treeb13781a5e80dc0c9361b4849ad9759f46b5b4857 /app-i18n
parentdev-ml/sexp_pretty: Stabilize 0.15.1-r1 arm, #901667 (diff)
downloadgentoo-a886a9ed89c2589c597f9c1d5a3b2167a663ed76.tar.gz
gentoo-a886a9ed89c2589c597f9c1d5a3b2167a663ed76.tar.bz2
gentoo-a886a9ed89c2589c597f9c1d5a3b2167a663ed76.zip
app-i18n/ibus-typing-booster: new upstream release
Signed-off-by: Akinori Hattori <hattya@gentoo.org>
Diffstat (limited to 'app-i18n')
-rw-r--r--app-i18n/ibus-typing-booster/Manifest1
-rw-r--r--app-i18n/ibus-typing-booster/ibus-typing-booster-2.22.4.ebuild54
2 files changed, 55 insertions, 0 deletions
diff --git a/app-i18n/ibus-typing-booster/Manifest b/app-i18n/ibus-typing-booster/Manifest
index 687d9bb37b76..2d964abbef95 100644
--- a/app-i18n/ibus-typing-booster/Manifest
+++ b/app-i18n/ibus-typing-booster/Manifest
@@ -1,3 +1,4 @@
DIST ibus-typing-booster-2.21.4.tar.gz 11220794 BLAKE2B 7e5c7b9be31858ce1be7399b7dbada4cdec5a24f9d4f66d4e5ea110153d4696aa794650048b40dc52044ad90514f051a60234835d9b3c59aadb05aa6ba9eef4b SHA512 26dbc8cee8e6a6ec0414fc3e2f26298665030babed7f7dba7f52b5260b9aba511ab456fe49fb779f66b66b4db9fbe81faeec8692ad8a101e518d6fcf80189fd8
DIST ibus-typing-booster-2.22.1.tar.gz 11322188 BLAKE2B f9119aecd57c1f6581035548c53ceda529cee67636760bca0540e9fd91d92440fa3f8df5fb1065db2a131d20942519482f6b7cbee1cc7f74c58e01344bf07fa1 SHA512 c979c1e58c038ba6b5a07223e74c080f8d5f2c45b9f60c279aba49bb98c51a13b8922f5c167a2bfd07ccd9c7dbdf56ff784379124f6425ead0d16cc9dd5ced43
DIST ibus-typing-booster-2.22.3.tar.gz 11322959 BLAKE2B 7a09502ef3a1b3bbeaf231ae53b6c283ea582ccde96706e1b11ea3a46903efe0fe4d02f631b8a9b58d1c7971ae76e320a46d23ca915b2459bcc644c78a611eb2 SHA512 d3ea8825222e1a4c5c3aa64f947e7ffccd7e7fac9489b29126c1f10d560d4f959e1c8b8e718ecfd1367b6bdc698b346e022c4681dbd24a4f91005c579f397a9c
+DIST ibus-typing-booster-2.22.4.tar.gz 11324323 BLAKE2B 4615148eae8fb30c281e5288008277b54f7e934e0c7f9c210a4bb0f38e513d10bbd8b0880c13bb05c1f50fc8cbfb4e46779c12a08860578d94d294b1957f4b2c SHA512 1da2d23c33f991b67127ba0df5d6e630252b66fe0c1bdb4018cf8c495146ec32f72a3d25998a511cebdf3b0d41583b19e8d2706b08faa3cacddd56327602c09a
diff --git a/app-i18n/ibus-typing-booster/ibus-typing-booster-2.22.4.ebuild b/app-i18n/ibus-typing-booster/ibus-typing-booster-2.22.4.ebuild
new file mode 100644
index 000000000000..564f684f9809
--- /dev/null
+++ b/app-i18n/ibus-typing-booster/ibus-typing-booster-2.22.4.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="8"
+PYTHON_COMPAT=( python3_{9..11} )
+PYTHON_REQ_USE="sqlite(+)"
+
+inherit gnome2-utils python-single-r1 xdg
+
+DESCRIPTION="Completion input method for IBus"
+HOMEPAGE="https://mike-fabian.github.io/ibus-typing-booster"
+SRC_URI="https://github.com/mike-fabian/${PN}/releases/download/${PV}/${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+RESTRICT="test"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+DEPEND="${PYTHON_DEPS}
+ dev-libs/m17n-lib
+ $(python_gen_cond_dep '
+ app-i18n/ibus[python(+),${PYTHON_USEDEP}]
+ dev-python/dbus-python[${PYTHON_USEDEP}]
+ dev-python/pyenchant[${PYTHON_USEDEP}]
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+ dev-python/pyxdg[${PYTHON_USEDEP}]
+ ')"
+RDEPEND="${DEPEND}
+ >=dev-db/m17n-db-1.7"
+BDEPEND="sys-devel/gettext
+ virtual/pkgconfig"
+
+src_prepare() {
+ default
+
+ sed -i "s|/usr\(/bin/sh\)|\1|" {engine,setup}/*.in
+}
+
+pkg_preinst() {
+ xdg_pkg_preinst
+ gnome2_schemas_savelist
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}