summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2022-04-13 22:13:01 -0700
committerMatt Turner <mattst88@gentoo.org>2022-04-15 12:24:58 -0700
commitaec6e5b6cd8285b05259432c20368d46d667d663 (patch)
treeb638678f23a35ad64c2240453d3776c2a033761e /app-i18n
parentapp-i18n/ibus: Split IUSE=+gtk3 from IUSE=+gtk (diff)
downloadgentoo-aec6e5b6cd8285b05259432c20368d46d667d663.tar.gz
gentoo-aec6e5b6cd8285b05259432c20368d46d667d663.tar.bz2
gentoo-aec6e5b6cd8285b05259432c20368d46d667d663.zip
app-i18n/ibus: Fix gtk-related REQUIRED_USE
IUSE=gtk2 only controls the GTK+2 IM module; there's no need for it to depend on IUSE=gtk, which controls the UI. However client/x11/Makefile.am contains: if ENABLE_GTK3 GTK_CFLAGS = @GTK3_CFLAGS@ GTK_LIBS = @GTK3_LIBS@ else GTK_CFLAGS = @GTK2_CFLAGS@ GTK_LIBS = @GTK2_LIBS@ endif and configure.ac contains: if test x"$enable_xim" = x"yes"; then [...] # if we don't have gtk3 yet, check for gtk2 if test x"$enable_gtk3" != x"yes"; then # check for gtk2 PKG_CHECK_MODULES(GTK2, [ gtk+-2.0 ]) fi [...] fi so we do want REQUIRED_USE="xim? ( gtk3 )" to prevent any accidental gtk+2 usage. Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'app-i18n')
-rw-r--r--app-i18n/ibus/ibus-1.5.26.ebuild7
1 files changed, 3 insertions, 4 deletions
diff --git a/app-i18n/ibus/ibus-1.5.26.ebuild b/app-i18n/ibus/ibus-1.5.26.ebuild
index 3bba87ebd2c2..bcf13d3d4633 100644
--- a/app-i18n/ibus/ibus-1.5.26.ebuild
+++ b/app-i18n/ibus/ibus-1.5.26.ebuild
@@ -22,15 +22,15 @@ KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86"
IUSE="+X appindicator +emoji +gtk +gtk2 +gtk3 +gtk4 +introspection nls +python systemd test +unicode vala wayland"
RESTRICT="!test? ( test )"
REQUIRED_USE="
- gtk2? ( gtk )
appindicator? ( gtk3 )
python? (
${PYTHON_REQUIRED_USE}
introspection
)
test? ( gtk3 )
- vala? ( introspection )"
-
+ vala? ( introspection )
+ X? ( gtk3 )
+"
DEPEND="
app-text/iso-codes
>=dev-libs/glib-2.65.0:2
@@ -40,7 +40,6 @@ DEPEND="
X? (
x11-libs/libX11
>=x11-libs/libXfixes-6.0.0
- !gtk? ( x11-libs/gtk+:2 )
)
gtk? (
x11-libs/libX11