summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Sokolov <sokolov@google.com>2020-04-26 12:08:19 +0100
committerAkinori Hattori <hattya@gentoo.org>2020-05-20 22:45:18 +0900
commitd9e8bbccdce70a295fff39af4f7cbac5c48902e6 (patch)
tree13bf461843ecf87a7552af6b51746610c32ca8de /app-i18n
parentapp-i18n/fbterm: version bump to 1.7_p20190503 (diff)
downloadgentoo-d9e8bbccdce70a295fff39af4f7cbac5c48902e6.tar.gz
gentoo-d9e8bbccdce70a295fff39af4f7cbac5c48902e6.tar.bz2
gentoo-d9e8bbccdce70a295fff39af4f7cbac5c48902e6.zip
app-i18n/fbterm: call ar through tc
Closes: https://bugs.gentoo.org/718356 Closes: https://github.com/gentoo/gentoo/pull/15467 Package-Manager: Portage-2.3.89, Repoman-2.3.20 Signed-off-by: Alexey Sokolov <sokolov@google.com> Signed-off-by: Akinori Hattori <hattya@gentoo.org>
Diffstat (limited to 'app-i18n')
-rw-r--r--app-i18n/fbterm/fbterm-1.7_p20190503.ebuild22
1 files changed, 11 insertions, 11 deletions
diff --git a/app-i18n/fbterm/fbterm-1.7_p20190503.ebuild b/app-i18n/fbterm/fbterm-1.7_p20190503.ebuild
index 92924b9b17b2..1c56f62e76bc 100644
--- a/app-i18n/fbterm/fbterm-1.7_p20190503.ebuild
+++ b/app-i18n/fbterm/fbterm-1.7_p20190503.ebuild
@@ -3,30 +3,26 @@
EAPI="7"
-inherit autotools fcaps
+inherit autotools fcaps toolchain-funcs vcs-snapshot
+
+EGIT_COMMIT="ccea326dd73f4d6b6442fde7ba7c2be9cd35c6df"
DESCRIPTION="Fast terminal emulator for the Linux framebuffer"
HOMEPAGE="https://github.com/gjedeer/fbterm"
-MY_COMMIT="ccea326dd73f4d6b6442fde7ba7c2be9cd35c6df"
-SRC_URI="https://github.com/gjedeer/fbterm/archive/${MY_COMMIT}.tar.gz -> ${P}.tar.gz"
-S="${WORKDIR}/fbterm-${MY_COMMIT}"
+SRC_URI="https://github.com/gjedeer/fbterm/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~arm ~arm64 ~x86"
IUSE="gpm video_cards_vesa"
-DEPEND="
- media-libs/fontconfig
+DEPEND="media-libs/fontconfig
media-libs/freetype:2
>=sys-libs/ncurses-6.1
gpm? ( sys-libs/gpm )
- video_cards_vesa? ( dev-libs/libx86 )
-"
-BDEPEND="
- virtual/pkgconfig
-"
+ video_cards_vesa? ( dev-libs/libx86 )"
+BDEPEND="virtual/pkgconfig"
FILECAPS=(
cap_sys_tty_config+ep usr/bin/${PN}
@@ -46,6 +42,10 @@ src_configure() {
$(use_enable video_cards_vesa vesa)
}
+src_compile() {
+ emake AR="$(tc-getAR)"
+}
+
src_install() {
default