summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIoan-Adrian Ratiu <adi@adirat.com>2015-11-11 20:37:47 +0200
committerIoan-Adrian Ratiu <adi@adirat.com>2015-11-12 12:58:40 +0200
commit4b4234a933a25f93131c443b51cc3bd5b79ce345 (patch)
tree2589bb4ea22ea08f1fd2385c94d0f63fa6d6a03d /app-laptop/i8kutils/i8kutils-1.42.ebuild
parentdev-python/pylint: Depend on threading support in python (diff)
downloadgentoo-4b4234a933a25f93131c443b51cc3bd5b79ce345.tar.gz
gentoo-4b4234a933a25f93131c443b51cc3bd5b79ce345.tar.bz2
gentoo-4b4234a933a25f93131c443b51cc3bd5b79ce345.zip
app-laptop/i8kutils: fix gcc5 build for v1.42
Recipe enhancements requested in the bug are also included Gentoo bug: #565466 Signed-off-by: Ioan-Adrian Ratiu <adi@adirat.com>
Diffstat (limited to 'app-laptop/i8kutils/i8kutils-1.42.ebuild')
-rw-r--r--app-laptop/i8kutils/i8kutils-1.42.ebuild17
1 files changed, 7 insertions, 10 deletions
diff --git a/app-laptop/i8kutils/i8kutils-1.42.ebuild b/app-laptop/i8kutils/i8kutils-1.42.ebuild
index ae16f20aee49..5d4cde5661f3 100644
--- a/app-laptop/i8kutils/i8kutils-1.42.ebuild
+++ b/app-laptop/i8kutils/i8kutils-1.42.ebuild
@@ -4,7 +4,7 @@
EAPI=5
-inherit systemd toolchain-funcs
+inherit eutils systemd toolchain-funcs
DESCRIPTION="Dell Inspiron and Latitude utilities"
HOMEPAGE="https://launchpad.net/i8kutils"
@@ -13,7 +13,7 @@ SRC_URI="https://launchpad.net/i8kutils/trunk/${PV}/+download/${P/-/_}.tar.xz"
LICENSE="GPL-3"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE="examples tk"
+IUSE="tk"
DEPEND="tk? ( dev-lang/tk:0 )"
RDEPEND="${DEPEND}
@@ -24,11 +24,8 @@ S="${WORKDIR}/${PN}"
DOCS=( README.i8kutils )
src_prepare() {
- sed \
- -e '/^CC/d' \
- -e '/^CFLAGS/d' \
- -e 's: -g : $(LDFLAGS) :g' \
- -i Makefile || die
+ epatch "${FILESDIR}/${PN}-gcc5.patch"
+ epatch "${FILESDIR}/${P}-Makefile.patch"
tc-export CC
}
@@ -36,10 +33,10 @@ src_prepare() {
src_install() {
dobin i8kctl i8kfan
doman i8kctl.1
-
- use examples && dodoc -r examples
+ dodoc README.i8kutils
newinitd "${FILESDIR}"/i8k.init-r1 i8k
+ newconfd "${FILESDIR}"/i8k.conf i8k
if use tk; then
dobin i8kmon
@@ -48,9 +45,9 @@ src_install() {
systemd_dounit "${FILESDIR}"/i8kmon.service
else
cat >> "${ED}"/etc/conf.d/i8k <<- EOF
+
# i8kmon disabled because the package was installed without USE=tk
NOMON=1
EOF
fi
-
}