summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGöktürk Yüksek <gokturk@gentoo.org>2019-11-01 14:35:27 -0400
committerGöktürk Yüksek <gokturk@gentoo.org>2019-11-01 14:37:38 -0400
commitd81ee2f236dc123b9f7dba45c28309b4a5e2348f (patch)
tree2592251af349ed01ee9cb13cc927223c3b4bbf4b /app-laptop/mbpfan
parentwww-client/chromium: stable channel bump to 78.0.3904.87 (diff)
downloadgentoo-d81ee2f236dc123b9f7dba45c28309b4a5e2348f.tar.gz
gentoo-d81ee2f236dc123b9f7dba45c28309b4a5e2348f.tar.bz2
gentoo-d81ee2f236dc123b9f7dba45c28309b4a5e2348f.zip
app-laptop/mbpfan: bump to 2.2.0
Package-Manager: Portage-2.3.78, Repoman-2.3.17 Signed-off-by: Göktürk Yüksek <gokturk@gentoo.org>
Diffstat (limited to 'app-laptop/mbpfan')
-rw-r--r--app-laptop/mbpfan/Manifest1
-rw-r--r--app-laptop/mbpfan/mbpfan-2.2.0.ebuild47
2 files changed, 48 insertions, 0 deletions
diff --git a/app-laptop/mbpfan/Manifest b/app-laptop/mbpfan/Manifest
index 0af7c168aa49..86ba4a5265d3 100644
--- a/app-laptop/mbpfan/Manifest
+++ b/app-laptop/mbpfan/Manifest
@@ -3,3 +3,4 @@ DIST mbpfan-2.0.0.tar.gz 37912 BLAKE2B 8d2ce41d8f6a724e28ace0c23047dde4a0a60ae10
DIST mbpfan-2.0.1.tar.gz 37805 BLAKE2B 0988a9b5cd359b4e64fdb1e63322dea7582fdc9a9dda0760550945282ef6142dbcab8aeb78ec1a725b5f9aebcda72386e3fa4b8b5f7ecdf078106d229fb7e2af SHA512 8fd2e37b9b81720ff7efa490d285da5980ef5dcc858fef4b0c24166a8f0df46aa230ea18fca5775b222271918e5ca6df1bfbbdced068182c20eeb86192ed2019
DIST mbpfan-2.1.0.tar.gz 39303 BLAKE2B b51b7df8c24cc49561f45614a655c698b85f149367f888aceb90b90e27e2da03ede7beed58e552e163e9f625d950290198f6d56a545c10989a8d0e27909556a7 SHA512 8750ac47419e84f8692a478e3977b56b98be9e255d5be9876094eef0f86bc587510959cc4cff0d681fb9e1ecaf98f90d9d0b63a1a6ddd25e8de4ccfda747b54a
DIST mbpfan-2.1.1.tar.gz 40637 BLAKE2B bdd17a9a883cc9af3cb7d55a2c8594c435fb367f0c6b5dec2b3da85747e2c2af591ed1dabf082cbbc31ac92ce5b2dc5194d8a50836c87cd784f238322ab09d9f SHA512 c1bf81c5e2f2f4f710a8455c65f10dc2dc2255319a7dbf4367c31884eece8d9909d28f3a00e5fc4d964d65254b36202a2a2b666d0ef04ea04153baded6039449
+DIST mbpfan-2.2.0.tar.gz 40435 BLAKE2B 6fd9e6e7c480faa8c0ea432404ec5fcbe8bc8b17efba5dcce28dae96b8c8c434bbf712208e4d7a2f5b12e6d5d1535e3bf32b4661a78c69f496d9c43c3c232bb8 SHA512 f45eb3965100dbc88ba7bf15a15fee261b0f5f29174b7d7d1c1a6d6752ded3ba909586d9131d325d40826a38005ecb3a33008192565b9bb802ffe49c37274690
diff --git a/app-laptop/mbpfan/mbpfan-2.2.0.ebuild b/app-laptop/mbpfan/mbpfan-2.2.0.ebuild
new file mode 100644
index 000000000000..b530d9569fa7
--- /dev/null
+++ b/app-laptop/mbpfan/mbpfan-2.2.0.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit linux-info systemd toolchain-funcs
+
+DESCRIPTION="A simple daemon to control fan speed on all Macbook/Macbook Pros"
+HOMEPAGE="https://github.com/dgraziotin/mbpfan"
+LICENSE="GPL-3+"
+SLOT="0"
+RESTRICT="test" # will fail if the hardware is unavailable, not useful
+
+if [[ "${PV}" = 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/dgraziotin/${PN}.git"
+ KEYWORDS=""
+else
+ SRC_URI="https://github.com/dgraziotin/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+CONFIG_CHECK="~SENSORS_APPLESMC ~SENSORS_CORETEMP"
+
+src_compile() {
+ emake CC="$(tc-getCC)"
+}
+
+src_install() {
+ emake DESTDIR="${ED}" install
+
+ # Decompress the man page to enable PM auto compression
+ gzip -d "${ED}"/usr/share/man/man8/mbpfan.8.gz || die
+
+ # Remove the empty systemd unit directory
+ # It doesn't actually install the unit file
+ rmdir --ignore-fail-on-non-empty -p "${ED%/}/lib/systemd/system" || die
+ # Actually install the sytstemd unit file
+ systemd_dounit ${PN}.service
+ # Install openrc init file
+ newinitd ${PN}.init.gentoo ${PN}
+
+ # make install doesn't install the docs in the right place
+ rm -rf "${ED%/}/usr/share/doc/${PN}" || die
+
+ einstalldocs
+}