summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAustin English <wizardedit@gentoo.org>2016-04-26 11:50:05 -0500
committerAustin English <wizardedit@gentoo.org>2016-04-26 11:50:05 -0500
commit049085bd1fd0bad083e9b3edc42660a2f4b649d8 (patch)
treeecd6c7db46a5fff189bc873d940bbb8416c587b0 /app-laptop
parentwww-apache/mod_xml2enc: remove implicit system dep (diff)
downloadgentoo-049085bd1fd0bad083e9b3edc42660a2f4b649d8.tar.gz
gentoo-049085bd1fd0bad083e9b3edc42660a2f4b649d8.tar.bz2
gentoo-049085bd1fd0bad083e9b3edc42660a2f4b649d8.zip
app-laptop/tp_smapi: use #!/sbin/openrc-run instead of #!/sbin/runscript
Gentoo-Bug: https://bugs.gentoo.org/show_bug.cgi?id=573846 Package-Manager: portage-2.2.26
Diffstat (limited to 'app-laptop')
-rw-r--r--app-laptop/tp_smapi/files/tp_smapi-0.40-initd2
-rw-r--r--app-laptop/tp_smapi/tp_smapi-0.41-r2.ebuild75
2 files changed, 76 insertions, 1 deletions
diff --git a/app-laptop/tp_smapi/files/tp_smapi-0.40-initd b/app-laptop/tp_smapi/files/tp_smapi-0.40-initd
index e0b3bd5e0d8e..3b8c10d9274a 100644
--- a/app-laptop/tp_smapi/files/tp_smapi-0.40-initd
+++ b/app-laptop/tp_smapi/files/tp_smapi-0.40-initd
@@ -1,4 +1,4 @@
-#!/sbin/runscript
+#!/sbin/openrc-run
# Copyright (C) 2011 Henning Schild <henning@wh9.tu-dresden.de>
# Copyright (C) 2011 Sebastian Pipping <sebastian@pipping.org>
#
diff --git a/app-laptop/tp_smapi/tp_smapi-0.41-r2.ebuild b/app-laptop/tp_smapi/tp_smapi-0.41-r2.ebuild
new file mode 100644
index 000000000000..e32c1f3b639b
--- /dev/null
+++ b/app-laptop/tp_smapi/tp_smapi-0.41-r2.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit flag-o-matic linux-mod
+
+DESCRIPTION="IBM ThinkPad SMAPI BIOS driver"
+HOMEPAGE="https://github.com/evgeni/tp_smapi/ http://tpctl.sourceforge.net/"
+SRC_URI="mirror://github/evgeni/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+IUSE="hdaps"
+
+RESTRICT="userpriv"
+
+# We need dmideode if the kernel does not support DMI_DEV_TYPE_OEM_STRING
+# in dmi.h
+DEPEND="sys-apps/dmidecode"
+RDEPEND="${DEPEND}"
+
+pkg_pretend() {
+ linux-mod_pkg_setup
+
+ if kernel_is lt 2 6 19; then
+ eerror
+ eerror "${P} requires Linux kernel 2.6.19 or above."
+ eerror
+ die "Unsupported kernel version"
+ fi
+
+ MODULE_NAMES="thinkpad_ec(extra:) tp_smapi(extra:)"
+ BUILD_PARAMS="KSRC=${KV_DIR} KBUILD=${KV_OUT_DIR}"
+ BUILD_TARGETS="default"
+
+ if use hdaps; then
+ CONFIG_CHECK="~INPUT_UINPUT"
+ WARNING_INPUT_UINPUT="Your kernel needs uinput for the hdaps module to perform better"
+ linux-info_pkg_setup
+
+ MODULE_NAMES="${MODULE_NAMES} hdaps(extra:)"
+ BUILD_PARAMS="${BUILD_PARAMS} HDAPS=1"
+
+ CONFIG_CHECK="~!SENSORS_HDAPS"
+ ERROR_SENSORS_HDAPS="${P} with USE=hdaps conflicts with in-kernel HDAPS (CONFIG_SENSORS_HDAPS)"
+ linux-info_pkg_setup
+ fi
+}
+
+pkg_setup() {
+ # run again as pkg_pretend is not var safe
+ pkg_pretend
+}
+
+src_compile() {
+ # Kernel Makefiles may pull in -mpreferred-stack-boundary=3
+ # which requires that SSE disabled or compilation will fail.
+ # So we need to ensure that appended user CLAGS do not re-enable SSE
+ # https://bugs.gentoo.org/show_bug.cgi?id=492964
+ replace-flags '-msse*' ''
+ replace-flags '-mssse3' ''
+
+ linux-mod_src_compile
+}
+
+src_install() {
+ linux-mod_src_install
+ dodoc CHANGES README
+ newinitd "${FILESDIR}"/${PN}-0.40-initd smapi
+ newconfd "${FILESDIR}"/${PN}-0.40-confd smapi
+}