summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarc Schiffbauer <mschiff@gentoo.org>2021-03-17 23:53:28 -0500
committerMarc Schiffbauer <mschiff@gentoo.org>2021-03-17 23:56:18 -0500
commit0c635a9098c3117fcc0695cd23b775ea56a4964d (patch)
tree2b4220ee354bf5a206c5e4e78484875f7dcfe57b /app-laptop
parentnet-misc/networkmanager: bump to v1.30.2 (diff)
downloadgentoo-0c635a9098c3117fcc0695cd23b775ea56a4964d.tar.gz
gentoo-0c635a9098c3117fcc0695cd23b775ea56a4964d.tar.bz2
gentoo-0c635a9098c3117fcc0695cd23b775ea56a4964d.zip
app-laptop/tuxedo-keyboard: add new version
Closes: https://bugs.gentoo.org/761379 Package-Manager: Portage-3.0.13, Repoman-3.0.2 Signed-off-by: Marc Schiffbauer <mschiff@gentoo.org>
Diffstat (limited to 'app-laptop')
-rw-r--r--app-laptop/tuxedo-keyboard/Manifest1
-rw-r--r--app-laptop/tuxedo-keyboard/tuxedo-keyboard-3.0.3.ebuild23
2 files changed, 24 insertions, 0 deletions
diff --git a/app-laptop/tuxedo-keyboard/Manifest b/app-laptop/tuxedo-keyboard/Manifest
index 6f792af44007..7813aa7db01a 100644
--- a/app-laptop/tuxedo-keyboard/Manifest
+++ b/app-laptop/tuxedo-keyboard/Manifest
@@ -1 +1,2 @@
DIST tuxedo-keyboard-2.0.5.tar.gz 31001 BLAKE2B 931d011e2ac521cef1670a8952886c1ac9b2476c6227c2b3cfce28d52622d3869f3c55773279eea3cbcc94d7c5b12d5d5653a8e2f9c142d0c044fa23fddd958c SHA512 3b7a9331d04e2918f3452f9561b05f39ea458960c2ade299a368899638987178cfd33fa066a0835f88b14c240d7937692d7994ccf978749ea7fdc428e587e06a
+DIST tuxedo-keyboard-3.0.3.tar.gz 48275 BLAKE2B be4fd4a52cd578ec7db2d0f94c64ba842c2b28ecabbca10331024e104cf4dbaa655e0686f412141ac3ad6bc0430398797f628139a396e5a41ac73c33943230cf SHA512 6ebbde6ea9351f9fd7167d38d8b5f836d1fda2fbbcf80755e86c2b76c49cf263ad2e9cfc47bea3449387626d88d8c1725335c2861ec2ff5a76e64ef87e27d9fb
diff --git a/app-laptop/tuxedo-keyboard/tuxedo-keyboard-3.0.3.ebuild b/app-laptop/tuxedo-keyboard/tuxedo-keyboard-3.0.3.ebuild
new file mode 100644
index 000000000000..209f68c72490
--- /dev/null
+++ b/app-laptop/tuxedo-keyboard/tuxedo-keyboard-3.0.3.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit linux-mod toolchain-funcs
+
+DESCRIPTION="Kernel Module for Tuxedo Keyboard"
+HOMEPAGE="https://github.com/tuxedocomputers/tuxedo-keyboard"
+SRC_URI="https://github.com/tuxedocomputers/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+BUILD_TARGETS="all"
+MODULE_NAMES="clevo_acpi(tuxedo:${S}:src) clevo_wmi(tuxedo:${S}:src) tuxedo_keyboard(tuxedo:${S}:src) tuxedo_io(tuxedo:${S}:src/tuxedo_io)"
+
+pkg_setup() {
+ linux-mod_pkg_setup
+ BUILD_PARAMS="CC=$(tc-getBUILD_CC) KDIR=${KV_DIR} V=1 KBUILD_VERBOSE=1"
+}