summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-02-03 04:36:25 +0000
committerSam James <sam@gentoo.org>2023-02-03 05:07:36 +0000
commit2a81c18817d60a635f9b2dde9e32434b7904339e (patch)
tree9506da943e1bcb2fad84d56b076e959761fb0d3b /app-laptop
parentprofiles: unmmask gkrellm for a stay of execution (diff)
downloadgentoo-2a81c18817d60a635f9b2dde9e32434b7904339e.tar.gz
gentoo-2a81c18817d60a635f9b2dde9e32434b7904339e.tar.bz2
gentoo-2a81c18817d60a635f9b2dde9e32434b7904339e.zip
app-laptop/ibam: modernise a bit
Force C++03 given it uses features removed from C++11. Bug: https://bugs.gentoo.org/892251 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-laptop')
-rw-r--r--app-laptop/ibam/ibam-0.5.2-r5.ebuild18
1 files changed, 12 insertions, 6 deletions
diff --git a/app-laptop/ibam/ibam-0.5.2-r5.ebuild b/app-laptop/ibam/ibam-0.5.2-r5.ebuild
index 6b5e4f8298ce..273072878913 100644
--- a/app-laptop/ibam/ibam-0.5.2-r5.ebuild
+++ b/app-laptop/ibam/ibam-0.5.2-r5.ebuild
@@ -1,26 +1,30 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
PATCH_LEVEL="2.1"
-inherit toolchain-funcs optfeature
+inherit flag-o-matic toolchain-funcs optfeature
DESCRIPTION="Intelligent Battery Monitor"
HOMEPAGE="https://ibam.sourceforge.net"
-SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz
- mirror://debian/pool/main/${PN:0:1}/${PN}/${PN}_${PV}-${PATCH_LEVEL}.diff.gz"
+SRC_URI="
+ mirror://sourceforge/${PN}/${P}.tar.gz
+ mirror://debian/pool/main/${PN:0:1}/${PN}/${PN}_${PV}-${PATCH_LEVEL}.diff.gz
+"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="gkrellm"
-RDEPEND="gkrellm? (
+RDEPEND="
+ gkrellm? (
app-admin/gkrellm:2[X]
x11-libs/gdk-pixbuf
x11-libs/gtk+:2
- )"
+ )
+"
DEPEND="${RDEPEND}"
BDEPEND="gkrellm? ( virtual/pkgconfig )"
@@ -35,6 +39,8 @@ PATCHES=(
src_compile() {
tc-export CXX PKG_CONFIG
+ append-cxxflags -std=c++03
+
emake
use gkrellm && emake krell
}