summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohannes Willem Fernhout <hfern@fernhout.info>2021-07-15 09:58:50 +0200
committerJoonas Niilola <juippis@gentoo.org>2021-07-16 10:01:52 +0300
commit33eac150eb795219de042536e7dbd6872407d302 (patch)
tree228c7e50b44b9b80783276acdf5eedcb6ed4239e /app-laptop
parentvirtual/jdk: copied stable to 1.8.0-r6, dropped old (diff)
downloadgentoo-33eac150eb795219de042536e7dbd6872407d302.tar.gz
gentoo-33eac150eb795219de042536e7dbd6872407d302.tar.bz2
gentoo-33eac150eb795219de042536e7dbd6872407d302.zip
app-laptop/thinkfan: version bump to 1.2.2
This is a maintenance release that fixes a long-standing bug in handling sensors that may disappear at runtime. Closes: https://bugs.gentoo.org/799104 Signed-off-by: Johannes Willem Fernhout <hfern@fernhout.info> Closes: https://github.com/gentoo/gentoo/pull/21650 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'app-laptop')
-rw-r--r--app-laptop/thinkfan/Manifest1
-rw-r--r--app-laptop/thinkfan/thinkfan-1.2.2.ebuild41
2 files changed, 42 insertions, 0 deletions
diff --git a/app-laptop/thinkfan/Manifest b/app-laptop/thinkfan/Manifest
index 783936bff988..4faf895a8d3e 100644
--- a/app-laptop/thinkfan/Manifest
+++ b/app-laptop/thinkfan/Manifest
@@ -1,2 +1,3 @@
DIST thinkfan-1.0.2.tar.gz 77653 BLAKE2B 1b40553380f9b873883f0dc587665f24cd2e07de7a7e743cb9f99a3282f380da2258265a612b1c97d2945fed31aee0d6cbc30ea2a18c0b212e877e7635eda336 SHA512 d9133538096a7c5757f599adfebc8217aa7334a102573d6757f03b5c012a09d600be923930fd9d62f4afa591f5eb7a70a1c328004bddef85494d1a7ce56b648f
DIST thinkfan-1.2.1.tar.gz 84253 BLAKE2B 5a816b8cadbc72424384966b0bc6bcf17070eec703584c348bc28cf8ee59e4d67a56d351f0c1d9d55328326b21134f0158bf976f86336bb5d59b81c137b96c83 SHA512 27db9f54c26a85093ff7b9f8a0e26f679e413489f608b561b819a702fd077a33e62197e41a1f1f4495c66daa1ac70603c063e6ac4cdd09d13f4005f73685152d
+DIST thinkfan-1.2.2.tar.gz 85779 BLAKE2B 55d3806756aa638d8a97b74a8b6142f58e4b805c319cea2be0c4022fba7b9c2eb286956752788197aa50ee2a07f1fe826657ba0b95a47832a9f4e0f5070f3f82 SHA512 7991ef9e1891e9f4d843a0421404d8ccdedf398777f44ed0c6c58070849a6eae70044a72bad4ad9595e9528551212db228bf868371fb9a642918a69d2b4e917c
diff --git a/app-laptop/thinkfan/thinkfan-1.2.2.ebuild b/app-laptop/thinkfan/thinkfan-1.2.2.ebuild
new file mode 100644
index 000000000000..d59a97b5a27a
--- /dev/null
+++ b/app-laptop/thinkfan/thinkfan-1.2.2.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake readme.gentoo-r1
+
+DESCRIPTION="Simple fan control program for thinkpads"
+HOMEPAGE="https://github.com/vmatare/thinkfan"
+SRC_URI="https://github.com/vmatare/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="atasmart nvidia +yaml"
+
+DEPEND="atasmart? ( dev-libs/libatasmart )
+ yaml? ( dev-cpp/yaml-cpp )"
+
+RDEPEND="${DEPEND}
+ nvidia? ( x11-drivers/nvidia-drivers )"
+
+DOC_CONTENTS="
+ Please read the documentation and copy an appropriate
+ file to /etc/thinkfan.conf.
+"
+
+src_configure() {
+ local mycmakeargs+=(
+ -DCMAKE_INSTALL_DOCDIR=/usr/share/doc/${PF}
+ -DUSE_NVML="$(usex nvidia)"
+ -DUSE_ATASMART="$(usex atasmart)"
+ -DUSE_YAML="$(usex yaml)"
+ )
+ cmake_src_configure
+}
+
+src_install() {
+ cmake_src_install
+ readme.gentoo_create_doc
+}