summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-05-07 05:10:18 +0100
committerSam James <sam@gentoo.org>2022-05-07 05:10:18 +0100
commita79b2c425a6eec6e12bb3b7ada85db240d3b2135 (patch)
tree5fefe4a84546dc69f19649a008bcdbe2af964cac /app-laptop
parentdev-util/edb-debugger: fix build with GCC 12 (diff)
downloadgentoo-a79b2c425a6eec6e12bb3b7ada85db240d3b2135.tar.gz
gentoo-a79b2c425a6eec6e12bb3b7ada85db240d3b2135.tar.bz2
gentoo-a79b2c425a6eec6e12bb3b7ada85db240d3b2135.zip
app-laptop/thinkfan: add 1.3.1
Closes: https://bugs.gentoo.org/841245 Closes: https://bugs.gentoo.org/832601 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-laptop')
-rw-r--r--app-laptop/thinkfan/Manifest1
-rw-r--r--app-laptop/thinkfan/thinkfan-1.3.1.ebuild40
2 files changed, 41 insertions, 0 deletions
diff --git a/app-laptop/thinkfan/Manifest b/app-laptop/thinkfan/Manifest
index 4faf895a8d3e..16edae6596fa 100644
--- a/app-laptop/thinkfan/Manifest
+++ b/app-laptop/thinkfan/Manifest
@@ -1,3 +1,4 @@
DIST thinkfan-1.0.2.tar.gz 77653 BLAKE2B 1b40553380f9b873883f0dc587665f24cd2e07de7a7e743cb9f99a3282f380da2258265a612b1c97d2945fed31aee0d6cbc30ea2a18c0b212e877e7635eda336 SHA512 d9133538096a7c5757f599adfebc8217aa7334a102573d6757f03b5c012a09d600be923930fd9d62f4afa591f5eb7a70a1c328004bddef85494d1a7ce56b648f
DIST thinkfan-1.2.1.tar.gz 84253 BLAKE2B 5a816b8cadbc72424384966b0bc6bcf17070eec703584c348bc28cf8ee59e4d67a56d351f0c1d9d55328326b21134f0158bf976f86336bb5d59b81c137b96c83 SHA512 27db9f54c26a85093ff7b9f8a0e26f679e413489f608b561b819a702fd077a33e62197e41a1f1f4495c66daa1ac70603c063e6ac4cdd09d13f4005f73685152d
DIST thinkfan-1.2.2.tar.gz 85779 BLAKE2B 55d3806756aa638d8a97b74a8b6142f58e4b805c319cea2be0c4022fba7b9c2eb286956752788197aa50ee2a07f1fe826657ba0b95a47832a9f4e0f5070f3f82 SHA512 7991ef9e1891e9f4d843a0421404d8ccdedf398777f44ed0c6c58070849a6eae70044a72bad4ad9595e9528551212db228bf868371fb9a642918a69d2b4e917c
+DIST thinkfan-1.3.1.tar.gz 87239 BLAKE2B 219c72ada289a7168ee41872080ff15329c80f2a75326d15b726606e95ed39279afb85f0d9b4d4efc6dc2d4ce81d34bfc31bd7f565a86b717830ddeb579a0618 SHA512 dbb92ab1a7f008ecb5c125b105191b9021cccf3b59f6dbd0fbdea03dd730b573214d8a44b219c4efd458a6cab94deae3bcbdca030db72e79ca221ba91f0c2c6c
diff --git a/app-laptop/thinkfan/thinkfan-1.3.1.ebuild b/app-laptop/thinkfan/thinkfan-1.3.1.ebuild
new file mode 100644
index 000000000000..316faa87672d
--- /dev/null
+++ b/app-laptop/thinkfan/thinkfan-1.3.1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake readme.gentoo-r1
+
+DESCRIPTION="Simple fan control program for thinkpads"
+HOMEPAGE="https://github.com/vmatare/thinkfan"
+SRC_URI="https://github.com/vmatare/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="atasmart nvidia +yaml"
+
+DEPEND="atasmart? ( dev-libs/libatasmart )
+ yaml? ( dev-cpp/yaml-cpp )"
+RDEPEND="${DEPEND}
+ nvidia? ( x11-drivers/nvidia-drivers )"
+
+DOC_CONTENTS="
+ Please read the documentation and copy an appropriate
+ file to /etc/thinkfan.conf.
+"
+
+src_configure() {
+ local mycmakeargs+=(
+ -DCMAKE_INSTALL_DOCDIR=/usr/share/doc/${PF}
+ -DUSE_NVML="$(usex nvidia)"
+ -DUSE_ATASMART="$(usex atasmart)"
+ -DUSE_YAML="$(usex yaml)"
+ )
+ cmake_src_configure
+}
+
+src_install() {
+ cmake_src_install
+ readme.gentoo_create_doc
+}