summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Jolly <Matt.Jolly@footclan.ninja>2023-04-26 07:49:49 +1000
committerSam James <sam@gentoo.org>2023-05-13 03:58:50 +0100
commitb3e40e4bffc3c6894bf1b994bd34dd186ac7191e (patch)
tree2f078b5786a4adf33815ed72360fe14ad7caa9e2 /app-laptop
parentapp-laptop/tuxedo-control-center-bin: 1.2.4 add QA_PREBUILT (diff)
downloadgentoo-b3e40e4bffc3c6894bf1b994bd34dd186ac7191e.tar.gz
gentoo-b3e40e4bffc3c6894bf1b994bd34dd186ac7191e.tar.bz2
gentoo-b3e40e4bffc3c6894bf1b994bd34dd186ac7191e.zip
app-laptop/tuxedo-control-center-bin: drop 1.1.4
Signed-off-by: Matt Jolly <Matt.Jolly@footclan.ninja> Closes: https://github.com/gentoo/gentoo/pull/30759 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-laptop')
-rw-r--r--app-laptop/tuxedo-control-center-bin/Manifest1
-rw-r--r--app-laptop/tuxedo-control-center-bin/tuxedo-control-center-bin-1.1.4.ebuild80
2 files changed, 0 insertions, 81 deletions
diff --git a/app-laptop/tuxedo-control-center-bin/Manifest b/app-laptop/tuxedo-control-center-bin/Manifest
index 8e9f6a042b26..f20fcdd2658e 100644
--- a/app-laptop/tuxedo-control-center-bin/Manifest
+++ b/app-laptop/tuxedo-control-center-bin/Manifest
@@ -1,3 +1,2 @@
-DIST tuxedo-control-center_1.1.4.rpm 86231740 BLAKE2B be8b7d7c6de05601acd90a89b3e6bb89c5e251a94a18c7f1021e88797fbc1fc9c580545ca3d86e1ebf11f689d2454d4b6eac1736be0a31eabf28668d0ca0b32c SHA512 80e0c0f8ba81b8fe7bee2ec86b13a5f50c2a174b4260b7922a58df821a0b2ae89cd40c87e41c48de0a9e24a56ec1ad5123a664fc94123b95c05e61801db67072
DIST tuxedo-control-center_1.2.4.rpm 87792476 BLAKE2B 1d825b457be311da9022147eea8d86e17cc61c2c7decb5c334ad0f1cf44e7c0affe8026a650bcf6325fb21381fb4a17c3825a37c3815b489b059ea34b97f1794 SHA512 ac887b6681e6c56cd45f2c6f59dfb250c95f2a2ccdf1521c51126243461d680a7e7399a835672f1adf0512879fe7d69c8c7a3ca0e4ab217c3b617bfe41a7951d
DIST tuxedo-control-center_2.0.2.rpm 80479580 BLAKE2B 7c83fd64ee8d7ca8b50e3634d36567d3a930656c5e34f23fd7b703bc560d35376701df081aaa5d09692df61689a5a81ec87a8a4a8d55db2cc2577c638d02731b SHA512 e9c9abfc2c0d0e226038f49d388a31625120f6780558b7606e719be61a4563c698e4c46d6f0d6a3e774179a5f5785dc07ff243901578da474dfa80cf71fe0394
diff --git a/app-laptop/tuxedo-control-center-bin/tuxedo-control-center-bin-1.1.4.ebuild b/app-laptop/tuxedo-control-center-bin/tuxedo-control-center-bin-1.1.4.ebuild
deleted file mode 100644
index 512f3a375727..000000000000
--- a/app-laptop/tuxedo-control-center-bin/tuxedo-control-center-bin-1.1.4.ebuild
+++ /dev/null
@@ -1,80 +0,0 @@
-# Copyright 2021-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit rpm systemd xdg-utils
-
-MY_PN="${PN/-bin/}"
-
-DESCRIPTION="Tool to control performance, energy, fan and comfort settings on TUXEDO laptops"
-HOMEPAGE="https://github.com/tuxedocomputers/tuxedo-control-center"
-SRC_URI="https://rpm.tuxedocomputers.com/opensuse/15.2/x86_64/${MY_PN}_${PV}.rpm"
-
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="-* ~amd64"
-
-RESTRICT="strip splitdebug"
-
-DEPEND=">=app-laptop/tuxedo-keyboard-3.0.0"
-RDEPEND="${DEPEND}"
-# See bug #827729
-BDEPEND="app-arch/xz-utils[extra-filters]"
-
-S="${WORKDIR}"
-
-src_prepare() {
- default
- rm -rf usr/lib || die "could not remove usr/lib"
- mkdir files || die "could not create files dir"
-}
-
-src_install() {
- insinto /
- doins -r usr opt
- find . -type f -perm -a=x | while read f; do
- fperms 0755 "${f/./}"
- done
-
- dosym ../../opt/tuxedo-control-center/tuxedo-control-center /usr/bin/tuxedo-control-center
-
- insinto /usr/share/dbus-1/system.d/
- doins opt/tuxedo-control-center/resources/dist/tuxedo-control-center/data/dist-data/com.tuxedocomputers.tccd.conf
-
- insinto /usr/share/polkit-1/actions
- doins opt/tuxedo-control-center/resources/dist/tuxedo-control-center/data/dist-data/de.tuxedocomputers.tcc.policy
-
- systemd_dounit opt/tuxedo-control-center/resources/dist/tuxedo-control-center/data/dist-data/tccd.service
- systemd_dounit opt/tuxedo-control-center/resources/dist/tuxedo-control-center/data/dist-data/tccd-sleep.service
-
- newinitd "${FILESDIR}/tccd.initd" tccd
-}
-
-pkg_config() {
- ebegin "Reloading systemd"
- systemctl daemon-reload
- eend $?
- ebegin "Enabling and starting tccd.service"
- systemctl enable --now tccd
- eend $?
- ebegin "Enabling and starting tccd-sleep.service"
- systemctl enable --now tccd-sleep
- eend $?
-}
-
-pkg_postinst() {
- xdg_desktop_database_update
- xdg_icon_cache_update
- elog
- elog "You need to enable tccd and tccd-sleep service before running tuxedo-control-center"
- elog
- elog "For your convenience, if you use systemd, you may just call:"
- elog " emerge --config =app-laptop/${PF}"
- elog
-}
-
-pkg_postrm() {
- xdg_desktop_database_update
- xdg_icon_cache_update
-}