summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2022-08-01 00:51:45 +0200
committerDavid Seifert <soap@gentoo.org>2022-08-01 00:51:45 +0200
commitd107e7dadcc808bedfb6d0ff9cb1f161ce5db0e2 (patch)
tree1fa885f2f5d6e29d6159b40c01a326755d27094b /app-laptop
parentapp-laptop/mbpfan: drop 2.1.1 (diff)
downloadgentoo-d107e7dadcc808bedfb6d0ff9cb1f161ce5db0e2.tar.gz
gentoo-d107e7dadcc808bedfb6d0ff9cb1f161ce5db0e2.tar.bz2
gentoo-d107e7dadcc808bedfb6d0ff9cb1f161ce5db0e2.zip
app-laptop/mbpfan: update EAPI 6 -> 8
Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'app-laptop')
-rw-r--r--app-laptop/mbpfan/mbpfan-2.2.1-r1.ebuild (renamed from app-laptop/mbpfan/mbpfan-2.2.1.ebuild)17
1 files changed, 9 insertions, 8 deletions
diff --git a/app-laptop/mbpfan/mbpfan-2.2.1.ebuild b/app-laptop/mbpfan/mbpfan-2.2.1-r1.ebuild
index e1a4cb35e935..1bbd3102e15e 100644
--- a/app-laptop/mbpfan/mbpfan-2.2.1.ebuild
+++ b/app-laptop/mbpfan/mbpfan-2.2.1-r1.ebuild
@@ -1,17 +1,14 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=8
inherit linux-info systemd toolchain-funcs
DESCRIPTION="A simple daemon to control fan speed on all Macbook/Macbook Pros"
HOMEPAGE="https://github.com/dgraziotin/mbpfan"
-LICENSE="GPL-3+"
-SLOT="0"
-RESTRICT="test" # will fail if the hardware is unavailable, not useful
-if [[ "${PV}" = 9999 ]]; then
+if [[ ${PV} == *9999 ]]; then
inherit git-r3
EGIT_REPO_URI="https://github.com/dgraziotin/${PN}.git"
else
@@ -19,6 +16,10 @@ else
KEYWORDS="~amd64"
fi
+LICENSE="GPL-3+"
+SLOT="0"
+RESTRICT="test" # will fail if the hardware is unavailable, not useful
+
CONFIG_CHECK="~SENSORS_APPLESMC ~SENSORS_CORETEMP"
src_compile() {
@@ -33,14 +34,14 @@ src_install() {
# Remove the empty systemd unit directory
# It doesn't actually install the unit file
- rmdir --ignore-fail-on-non-empty -p "${ED%/}/lib/systemd/system" || die
+ rmdir --ignore-fail-on-non-empty -p "${ED}"/lib/systemd/system || die
# Actually install the sytstemd unit file
systemd_dounit ${PN}.service
# Install openrc init file
newinitd ${PN}.init.gentoo ${PN}
# make install doesn't install the docs in the right place
- rm -rf "${ED%/}/usr/share/doc/${PN}" || die
+ rm -r "${ED}"/usr/share/doc/${PN} || die
einstalldocs
}