summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMiroslav Šulc <fordfrog@gentoo.org>2021-09-07 07:21:16 +0200
committerMiroslav Šulc <fordfrog@gentoo.org>2021-09-07 07:21:16 +0200
commitf0998bf6fd60ef761d0db1bcb1289a357753fb98 (patch)
tree697c7ce646e94bcedf6672ad65741d3cb809e3eb /app-laptop
parentdev-python/snakeoil: Stabilize 0.9.7 hppa, #811663 (diff)
downloadgentoo-f0998bf6fd60ef761d0db1bcb1289a357753fb98.tar.gz
gentoo-f0998bf6fd60ef761d0db1bcb1289a357753fb98.tar.bz2
gentoo-f0998bf6fd60ef761d0db1bcb1289a357753fb98.zip
app-laptop/rogauracore: bump to 1.5
Package-Manager: Portage-3.0.22, Repoman-3.0.3 Signed-off-by: Miroslav Šulc <fordfrog@gentoo.org>
Diffstat (limited to 'app-laptop')
-rw-r--r--app-laptop/rogauracore/Manifest1
-rw-r--r--app-laptop/rogauracore/rogauracore-1.5.ebuild35
2 files changed, 36 insertions, 0 deletions
diff --git a/app-laptop/rogauracore/Manifest b/app-laptop/rogauracore/Manifest
index 6eb00cfc3443..0b12c9002c2a 100644
--- a/app-laptop/rogauracore/Manifest
+++ b/app-laptop/rogauracore/Manifest
@@ -1 +1,2 @@
DIST rogauracore-1.4.tar.gz 10305 BLAKE2B 27e94af50d318a3ce87f87236367aea72ee8daa2b0db896daeaa19bb75b6266faca2aca127d6444b759e6b7029c9f2eee1076ca4a197d70c4dfc2c611f5419ed SHA512 5179bfdfa8eeca5d7ac3ec87e4226429fa8d7987dc2d824a73a8a99142ceaf6fbda16f9844a62ecc8c629c44e334f940dff318bb3e2a3057c0bd1620d0f92c36
+DIST rogauracore-1.5.tar.gz 10442 BLAKE2B 1720ebd4808e814f0af77ed55027accd37645a0375eb3d29a814fe50624b8fadd2cde274cf0f33b87b83dd3be60d06513054df04f4e00a4e0168f5ff42d1ef50 SHA512 7ea47b9fa411ebe1176d9fbba3a814dbe67697d23b991547674f0ce2fd9b6536fce806e9dcf005f41de47f70bca543a7d8e77fa1fb35ed239ebc59a48746e1fc
diff --git a/app-laptop/rogauracore/rogauracore-1.5.ebuild b/app-laptop/rogauracore/rogauracore-1.5.ebuild
new file mode 100644
index 000000000000..a6678b687a8b
--- /dev/null
+++ b/app-laptop/rogauracore/rogauracore-1.5.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools
+
+if [[ ${PV} = "9999" ]]; then
+ EGIT_REPO_URI="https://github.com/wroberts/rogauracore.git"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/wroberts/${PN}/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+DESCRIPTION="RGB keyboard control for Asus ROG laptops"
+HOMEPAGE="https://github.com/wroberts/rogauracore"
+LICENSE="MIT"
+SLOT="0"
+
+DEPEND="virtual/libusb:="
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ econf
+}
+
+src_compile() {
+ emake
+}