summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
author0xd34df00d <0xd34df00d@gmail.com>2017-02-25 19:49:28 +0100
committerDavid Seifert <soap@gentoo.org>2017-02-26 12:58:56 +0100
commit09222bd0523d448c79f1434b042f55e440097adf (patch)
tree899893b57e6ed056d7eb0f4350388ccbedbc6b90 /app-leechcraft/lc-aggregator/lc-aggregator-9999.ebuild
parentprofiles/arch/hppa: Mask USE=libsecret for dev-vcs/git. (diff)
downloadgentoo-09222bd0523d448c79f1434b042f55e440097adf.tar.gz
gentoo-09222bd0523d448c79f1434b042f55e440097adf.tar.bz2
gentoo-09222bd0523d448c79f1434b042f55e440097adf.zip
app-leechcraft: use Qt5, modernize the eclass and ebuilds
Closes: https://github.com/gentoo/gentoo/pull/4079
Diffstat (limited to 'app-leechcraft/lc-aggregator/lc-aggregator-9999.ebuild')
-rw-r--r--app-leechcraft/lc-aggregator/lc-aggregator-9999.ebuild28
1 files changed, 14 insertions, 14 deletions
diff --git a/app-leechcraft/lc-aggregator/lc-aggregator-9999.ebuild b/app-leechcraft/lc-aggregator/lc-aggregator-9999.ebuild
index 151b1d8ba6e8..e79624969482 100644
--- a/app-leechcraft/lc-aggregator/lc-aggregator-9999.ebuild
+++ b/app-leechcraft/lc-aggregator/lc-aggregator-9999.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI="4"
+EAPI=6
inherit leechcraft
@@ -10,23 +10,23 @@ DESCRIPTION="Full-featured RSS/Atom feed reader for LeechCraft"
SLOT="0"
KEYWORDS=""
-IUSE="debug mysql +sqlite postgres webaccess"
-
-DEPEND="~app-leechcraft/lc-core-${PV}[postgres?,sqlite?]
- dev-qt/qtwebkit:4"
+IUSE="debug mysql +sqlite postgres"
+
+DEPEND="
+ ~app-leechcraft/lc-core-${PV}[postgres?,sqlite?]
+ dev-qt/qtcore:5
+ dev-qt/qtnetwork:5
+ dev-qt/qtprintsupport:5
+ dev-qt/qtsql:5[sqlite?,postgres?,mysql?]
+ dev-qt/qtwebkit:5
+ dev-qt/qtwidgets:5
+ dev-qt/qtxml:5"
RDEPEND="${DEPEND}
virtual/leechcraft-downloader-http"
REQUIRED_USE="|| ( mysql sqlite postgres )"
-src_configure() {
- local mycmakeargs=(
- $(cmake-utils_use_enale webaccess AGGREGATOR_WEBACCESS)
- )
- cmake-utils_src_configure
-}
-
-pkg_setup(){
+pkg_postinst(){
if use mysql; then
ewarn "Support for MySQL databases is experimental and is more likely"
ewarn "to contain bugs or mishandle your data than other storage"