summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
author0xd34df00d <0xd34df00d@gmail.com>2020-04-04 16:47:20 -0400
committerJoonas Niilola <juippis@gentoo.org>2020-04-09 15:37:42 +0300
commitb7a2d292c15368643f5458ca2534fdf405e4105c (patch)
tree1c4992f1647430c5cc7e0658f7f227caf51df654 /app-leechcraft/lc-aggregator
parentapp-leechcraft/lc-core: update boost dep (diff)
downloadgentoo-b7a2d292c15368643f5458ca2534fdf405e4105c.tar.gz
gentoo-b7a2d292c15368643f5458ca2534fdf405e4105c.tar.bz2
gentoo-b7a2d292c15368643f5458ca2534fdf405e4105c.zip
app-leechcraft/lc-aggregator: fix qtsql flags dependencies
sqlite, postgres, etc flags are only relevant at runtime for QtSql. Package-Manager: Portage-2.3.96, Repoman-2.3.22 Signed-off-by: Georg Rudoy <0xd34df00d@gmail.com> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'app-leechcraft/lc-aggregator')
-rw-r--r--app-leechcraft/lc-aggregator/lc-aggregator-9999.ebuild12
1 files changed, 7 insertions, 5 deletions
diff --git a/app-leechcraft/lc-aggregator/lc-aggregator-9999.ebuild b/app-leechcraft/lc-aggregator/lc-aggregator-9999.ebuild
index 1b1effd49285..cb80b05f0ae2 100644
--- a/app-leechcraft/lc-aggregator/lc-aggregator-9999.ebuild
+++ b/app-leechcraft/lc-aggregator/lc-aggregator-9999.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
inherit leechcraft
@@ -9,19 +9,21 @@ DESCRIPTION="Full-featured RSS/Atom feed reader for LeechCraft"
SLOT="0"
KEYWORDS=""
-IUSE="debug mysql +sqlite postgres"
+IUSE="debug mysql postgres +sqlite"
DEPEND="
- ~app-leechcraft/lc-core-${PV}[postgres?,sqlite?]
+ ~app-leechcraft/lc-core-${PV}[postgres?]
dev-qt/qtcore:5
dev-qt/qtnetwork:5
dev-qt/qtprintsupport:5
- dev-qt/qtsql:5[sqlite?,postgres?,mysql?]
+ dev-qt/qtsql:5
dev-qt/qtwebkit:5
dev-qt/qtwidgets:5
dev-qt/qtxml:5"
RDEPEND="${DEPEND}
- virtual/leechcraft-downloader-http"
+ dev-qt/qtsql:5[mysql?,postgres?,sqlite?]
+ virtual/leechcraft-downloader-http
+"
REQUIRED_USE="|| ( mysql sqlite postgres )"