summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
author0xd34df00d <0xd34df00d@gmail.com>2017-02-25 19:49:28 +0100
committerDavid Seifert <soap@gentoo.org>2017-02-26 12:58:56 +0100
commit09222bd0523d448c79f1434b042f55e440097adf (patch)
tree899893b57e6ed056d7eb0f4350388ccbedbc6b90 /app-leechcraft/lc-netstoremanager/lc-netstoremanager-9999.ebuild
parentprofiles/arch/hppa: Mask USE=libsecret for dev-vcs/git. (diff)
downloadgentoo-09222bd0523d448c79f1434b042f55e440097adf.tar.gz
gentoo-09222bd0523d448c79f1434b042f55e440097adf.tar.bz2
gentoo-09222bd0523d448c79f1434b042f55e440097adf.zip
app-leechcraft: use Qt5, modernize the eclass and ebuilds
Closes: https://github.com/gentoo/gentoo/pull/4079
Diffstat (limited to 'app-leechcraft/lc-netstoremanager/lc-netstoremanager-9999.ebuild')
-rw-r--r--app-leechcraft/lc-netstoremanager/lc-netstoremanager-9999.ebuild17
1 files changed, 8 insertions, 9 deletions
diff --git a/app-leechcraft/lc-netstoremanager/lc-netstoremanager-9999.ebuild b/app-leechcraft/lc-netstoremanager/lc-netstoremanager-9999.ebuild
index 6baf9d582de4..b4fba5b6b435 100644
--- a/app-leechcraft/lc-netstoremanager/lc-netstoremanager-9999.ebuild
+++ b/app-leechcraft/lc-netstoremanager/lc-netstoremanager-9999.ebuild
@@ -2,27 +2,26 @@
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI=4
+EAPI=6
inherit leechcraft
-DESCRIPTION="Plugin for supporting and managing Internet data storages like Yandex.Disk"
+DESCRIPTION="LeechCraft plugin for supporting cloud data storages like Google Drive"
SLOT="0"
KEYWORDS=""
-IUSE="+googledrive +yandexdisk"
+IUSE="+dropbox +googledrive"
DEPEND="~app-leechcraft/lc-core-${PV}
- googledrive? (
- dev-libs/qjson
- sys-apps/file
- )"
+ dev-qt/qtnetwork:5
+ dev-qt/qtwidgets:5
+"
RDEPEND="${DEPEND}"
src_configure(){
local mycmakeargs=(
- $(cmake-utils_use_enable googledrive NETSTOREMANAGER_GOOGLEDRIVE)
- $(cmake-utils_use_enable yandexdisk NETSTOREMANAGER_YANDEXDISK)
+ -DENABLE_NETSTOREMANAGER_DROPBOX=$(usex dropbox)
+ -DENABLE_NETSTOREMANAGER_GOOGLEDRIVE=$(usex googledrive)
)
cmake-utils_src_configure