summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-leechcraft/lc-ooronee/lc-ooronee-0.6.70.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-leechcraft/lc-ooronee/lc-ooronee-0.6.70.ebuild')
-rw-r--r--app-leechcraft/lc-ooronee/lc-ooronee-0.6.70.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/app-leechcraft/lc-ooronee/lc-ooronee-0.6.70.ebuild b/app-leechcraft/lc-ooronee/lc-ooronee-0.6.70.ebuild
new file mode 100644
index 000000000000..f49cc760167d
--- /dev/null
+++ b/app-leechcraft/lc-ooronee/lc-ooronee-0.6.70.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+inherit leechcraft
+
+DESCRIPTION="Quark handling text and images droppend onto it"
+
+SLOT="0"
+KEYWORDS=" ~amd64 ~x86"
+IUSE="debug"
+
+DEPEND="~app-leechcraft/lc-core-${PV}"
+RDEPEND="${DEPEND}
+ virtual/leechcraft-quark-sideprovider
+"
+
+# Grabbed from net-misc/netctl ebuild.
+optfeature() {
+ local desc=$1
+ shift
+ while (( $# )); do
+ if has_version "$1"; then
+ elog " [I] $1 to ${desc}"
+ else
+ elog " [ ] $1 to ${desc}"
+ fi
+ shift
+ done
+}
+
+pkg_postinst() {
+ elog "Install at least some of the following additional LeechCraft modules for Ooronee to be useful:"
+ optfeature "upload images" app-leechcraft/lc-imgaste app-leechcraft/lc-blasq
+ optfeature "search via OpenSearch" app-leechcraft/lc-seekthru
+ optfeature "search via Google" app-leechcraft/lc-pogooglue
+}