summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
author0xd34df00d <0xd34df00d@gmail.com>2020-04-18 19:38:38 +0200
committerJoonas Niilola <juippis@gentoo.org>2020-05-06 14:50:53 +0300
commit8eb2a39b3dd6dc14ce9526374e0d9e7a421f84f7 (patch)
tree5cfb512a7c20aadea8968b7fc42fc567d8ac301e /app-leechcraft
parentapp-leechcraft/lc-pintab: bump to EAPI=7 (diff)
downloadgentoo-8eb2a39b3dd6dc14ce9526374e0d9e7a421f84f7.tar.gz
gentoo-8eb2a39b3dd6dc14ce9526374e0d9e7a421f84f7.tar.bz2
gentoo-8eb2a39b3dd6dc14ce9526374e0d9e7a421f84f7.zip
app-leechcraft/lc-monocle: fix deps, update XDG db
Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Georg Rudoy <0xd34df00d@gmail.com> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'app-leechcraft')
-rw-r--r--app-leechcraft/lc-monocle/lc-monocle-9999.ebuild39
1 files changed, 25 insertions, 14 deletions
diff --git a/app-leechcraft/lc-monocle/lc-monocle-9999.ebuild b/app-leechcraft/lc-monocle/lc-monocle-9999.ebuild
index fcd13b3dd384..4b5bf380ecea 100644
--- a/app-leechcraft/lc-monocle/lc-monocle-9999.ebuild
+++ b/app-leechcraft/lc-monocle/lc-monocle-9999.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
-inherit leechcraft
+inherit xdg-utils leechcraft
DESCRIPTION="Monocle, the modular document viewer for LeechCraft"
@@ -13,20 +13,23 @@ IUSE="debug +djvu doc +fb2 +mobi +pdf +postscript"
REQUIRED_USE="postscript? ( pdf )"
-CDEPEND="~app-leechcraft/lc-core-${PV}
- dev-qt/qtnetwork:5
- dev-qt/qtwidgets:5
+DEPEND="~app-leechcraft/lc-core-${PV}
dev-qt/qtconcurrent:5
+ dev-qt/qtnetwork:5
dev-qt/qtprintsupport:5
+ dev-qt/qtwidgets:5
dev-qt/qtxml:5
- pdf? ( app-text/poppler[qt5] )
- djvu? ( app-text/djvu )"
+ djvu? ( app-text/djvu )
+ pdf? ( app-text/poppler:= )
+"
-RDEPEND="${CDEPEND}
- postscript? ( app-text/ghostscript-gpl )"
+RDEPEND="${DEPEND}
+ postscript? ( app-text/ghostscript-gpl )
+"
-DEPEND="${CDEPEND}
- doc? ( app-doc/doxygen[dot] )"
+BDEPEND="
+ doc? ( app-doc/doxygen[dot] )
+"
src_configure() {
local mycmakeargs=(
@@ -37,10 +40,18 @@ src_configure() {
-DENABLE_MONOCLE_PDF=$(usex pdf)
-DENABLE_MONOCLE_POSTRUS=$(usex postscript)
)
- cmake-utils_src_configure
+ cmake_src_configure
}
src_install() {
- cmake-utils_src_install
+ cmake_src_install
use doc && dodoc -r "${CMAKE_BUILD_DIR}"/out/html/*
}
+
+pkg_postinst() {
+ xdg_desktop_database_update
+}
+
+pkg_postrm() {
+ xdg_desktop_database_update
+}