summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2018-03-27 15:29:42 +0200
committerManuel Rüger <mrueg@gentoo.org>2018-03-27 15:29:42 +0200
commit2a43ec0e293653e9f0fe78f127e6b74f3f922f87 (patch)
tree8b7ebc932ea5462b6c5f0b919b801b50e9ca816d /app-metrics/prom2json/prom2json-0.1.0_p20170523.ebuild
parentdev-db/myodbc: Drop patch that was integrated upstream (diff)
downloadgentoo-2a43ec0e293653e9f0fe78f127e6b74f3f922f87.tar.gz
gentoo-2a43ec0e293653e9f0fe78f127e6b74f3f922f87.tar.bz2
gentoo-2a43ec0e293653e9f0fe78f127e6b74f3f922f87.zip
app-metrics/prom2json: Move package from app-admin/prom2json
Diffstat (limited to 'app-metrics/prom2json/prom2json-0.1.0_p20170523.ebuild')
-rw-r--r--app-metrics/prom2json/prom2json-0.1.0_p20170523.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/app-metrics/prom2json/prom2json-0.1.0_p20170523.ebuild b/app-metrics/prom2json/prom2json-0.1.0_p20170523.ebuild
new file mode 100644
index 000000000000..8bc84e323834
--- /dev/null
+++ b/app-metrics/prom2json/prom2json-0.1.0_p20170523.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit user golang-build golang-vcs-snapshot
+
+EGO_PN="github.com/prometheus/${PN}"
+EGIT_COMMIT="4a7436442837da72f9e211d99f0145dff3246b66"
+ARCHIVE_URI="https://${EGO_PN}/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
+KEYWORDS="~amd64"
+
+DESCRIPTION="A tool to scrape a Prometheus client and dump the result as JSON"
+HOMEPAGE="https://github.com/prometheus/prom2json"
+SRC_URI="${ARCHIVE_URI}"
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE=""
+
+DEPEND="dev-util/promu"
+
+src_prepare() {
+ default
+ sed -i -e "s/{{.Revision}}/${EGIT_COMMIT:0:7}/" src/${EGO_PN}/.promu.yml || die
+}
+
+src_compile() {
+ pushd src/${EGO_PN} || die
+ mkdir -p bin || die
+ GOPATH="${S}" promu build -v --prefix ${PN} || die
+ popd || die
+}
+
+src_install() {
+ pushd src/${EGO_PN} || die
+ dobin ${PN}/${PN}
+ dodoc {README,CONTRIBUTING}.md
+ popd || die
+}