summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMikle Kolyada <zlogene@gentoo.org>2021-07-03 10:30:33 +0300
committerMikle Kolyada <zlogene@gentoo.org>2021-07-03 10:30:57 +0300
commit9768dc687391d89184a298ae095368d0c01f21dd (patch)
tree4eb72abb7c8115485de3729be9cb770c711ca57e /app-metrics/prometheus-bin
parentdev-ruby/ruby2ruby: cleanup (diff)
downloadgentoo-9768dc687391d89184a298ae095368d0c01f21dd.tar.gz
gentoo-9768dc687391d89184a298ae095368d0c01f21dd.tar.bz2
gentoo-9768dc687391d89184a298ae095368d0c01f21dd.zip
app-metrics/prometheus-bin: Version bump (v2.28.1)
Package-Manager: Portage-3.0.20, Repoman-3.0.2 Signed-off-by: Mikle Kolyada <zlogene@gentoo.org>
Diffstat (limited to 'app-metrics/prometheus-bin')
-rw-r--r--app-metrics/prometheus-bin/Manifest1
-rw-r--r--app-metrics/prometheus-bin/prometheus-bin-2.28.1.ebuild51
2 files changed, 52 insertions, 0 deletions
diff --git a/app-metrics/prometheus-bin/Manifest b/app-metrics/prometheus-bin/Manifest
index 4f87133c5931..a3c34c4c44b5 100644
--- a/app-metrics/prometheus-bin/Manifest
+++ b/app-metrics/prometheus-bin/Manifest
@@ -1,2 +1,3 @@
DIST prometheus-2.26.1.linux-amd64.tar.gz 65179092 BLAKE2B 631dfbaf9d8553297bd763b2a1ce7cb97d66ec90bff126466868a59b0a0fe074fc13866e2c99f085c7257c3047ab4105f16508c1397de76a1420b4df0b203455 SHA512 53cbbef86204973a01e0d20b287cdbe2c1743dc2add0449d10da55dd3fbed95eaa5beb0a2cd08b4a33fb1825440c91633ef7680616d89838868216fafcd27c55
DIST prometheus-2.27.1.linux-amd64.tar.gz 69491886 BLAKE2B 7739bd6d84570d4d0db987a0b027ba875728245ded5fac17f89adddfd9b14543cd9594664a8d42392a7a018477ece69ac47367f03442c0f5b11a1e76140ad7c6 SHA512 df43385e178f698806181ab67db0b75600d356c7792f2dcfe6e3390a8a7b449f180ea8fccbc58c10ad0118cea1ba8d5664676de9741e5f91a1a4ec897baeb88f
+DIST prometheus-2.28.1.linux-amd64.tar.gz 71109475 BLAKE2B fe487ec0157e4c6de5319cdacaf99bba9784156b21b29245b65c1b090951bac182b6b2f5ab98615ac0424eb0984dcbea1fffaa680a9d424addbc73c2f923c483 SHA512 a58280f9013f3013a917019ad850f9150f9636e579a87a0408a7de943b3f807a65135452b5c65b75aeca7f62dccf5958a420755088cd3955cd6a556893ed68e4
diff --git a/app-metrics/prometheus-bin/prometheus-bin-2.28.1.ebuild b/app-metrics/prometheus-bin/prometheus-bin-2.28.1.ebuild
new file mode 100644
index 000000000000..da63a8595d37
--- /dev/null
+++ b/app-metrics/prometheus-bin/prometheus-bin-2.28.1.ebuild
@@ -0,0 +1,51 @@
+# Copyright 2020-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit systemd
+
+DESCRIPTION="prometheus monitoring system and time series database"
+HOMEPAGE="https://prometheus.io"
+MY_PN=${PN%%-bin}
+MY_P=${MY_PN}-${PV}
+SRC_URI="https://github.com/prometheus/prometheus/releases/download/v${PV}/${MY_P}.linux-amd64.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="-* ~amd64"
+
+QA_PREBUILT=".*"
+RESTRICT="strip"
+
+DEPEND="acct-group/prometheus
+ acct-user/prometheus
+ !app-metrics/prometheus"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${MY_P}.linux-amd64"
+
+src_install() {
+ dobin prometheus promtool
+ insinto /usr/share/prometheus
+ doins -r console_libraries consoles
+ insinto /etc/prometheus
+ doins prometheus.yml
+ dosym ../../usr/share/prometheus/console_libraries /etc/prometheus/console_libraries
+ dosym ../../usr/share/prometheus/consoles /etc/prometheus/consoles
+
+ systemd_dounit "${FILESDIR}"/prometheus.service
+ newinitd "${FILESDIR}"/prometheus.initd prometheus
+ newconfd "${FILESDIR}"/prometheus.confd prometheus
+ keepdir /var/log/prometheus /var/lib/prometheus
+ fowners prometheus:prometheus /var/log/prometheus /var/lib/prometheus
+}
+
+pkg_postinst() {
+ if has_version '<net-analyzer/prometheus-2.0.0_rc0'; then
+ ewarn "Old prometheus 1.x TSDB won't be converted to the new prometheus 2.0 format"
+ ewarn "Be aware that the old data currently cannot be accessed with prometheus 2.0"
+ ewarn "This release requires a clean storage directory and is not compatible with"
+ ewarn "files created by previous beta releases"
+ fi
+}