summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2018-12-16 13:14:44 +0100
committerManuel Rüger <mrueg@gentoo.org>2018-12-16 13:14:44 +0100
commit701acbaf50b302dc0d8231efc55b66471e7f0333 (patch)
tree17b5476ee7e99c8b88ecb0895aa4b94ba8bda649 /app-metrics/prometheus/prometheus-2.4.2.ebuild
parentdev-python/prometheus_client: Remove old (diff)
downloadgentoo-701acbaf50b302dc0d8231efc55b66471e7f0333.tar.gz
gentoo-701acbaf50b302dc0d8231efc55b66471e7f0333.tar.bz2
gentoo-701acbaf50b302dc0d8231efc55b66471e7f0333.zip
app-metrics/prometheus: Remove old
Signed-off-by: Manuel Rüger <mrueg@gentoo.org> Package-Manager: Portage-2.3.52, Repoman-2.3.11
Diffstat (limited to 'app-metrics/prometheus/prometheus-2.4.2.ebuild')
-rw-r--r--app-metrics/prometheus/prometheus-2.4.2.ebuild70
1 files changed, 0 insertions, 70 deletions
diff --git a/app-metrics/prometheus/prometheus-2.4.2.ebuild b/app-metrics/prometheus/prometheus-2.4.2.ebuild
deleted file mode 100644
index c4ee8b60e2be..000000000000
--- a/app-metrics/prometheus/prometheus-2.4.2.ebuild
+++ /dev/null
@@ -1,70 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-inherit user golang-build golang-vcs-snapshot
-
-EGO_PN="github.com/prometheus/prometheus"
-MY_PV=${PV/_rc/-rc.}
-EGIT_COMMIT="v${MY_PV}"
-PROMETHEUS_COMMIT="c305ffa"
-ARCHIVE_URI="https://${EGO_PN}/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
-KEYWORDS="~amd64"
-
-DESCRIPTION="Prometheus monitoring system and time series database"
-HOMEPAGE="https://github.com/prometheus/prometheus"
-SRC_URI="${ARCHIVE_URI}"
-LICENSE="Apache-2.0"
-SLOT="0"
-IUSE=""
-
-DEPEND="
- >=dev-lang/go-1.10
- dev-util/promu"
-
-PROMETHEUS_HOME="/var/lib/prometheus"
-
-RESTRICT="test"
-
-pkg_setup() {
- enewgroup prometheus
- enewuser prometheus -1 -1 "${PROMETHEUS_HOME}" prometheus
-}
-
-src_prepare() {
- default
- sed -i -e "s/{{.Revision}}/${PROMETHEUS_COMMIT}/" src/${EGO_PN}/.promu.yml || die
-}
-
-src_compile() {
- pushd src/${EGO_PN} || die
- GOPATH="${S}" promu build -v || die
- popd || die
-}
-
-src_install() {
- pushd src/${EGO_PN} || die
- dobin promtool prometheus
- dodoc -r {documentation,{README,CHANGELOG,CONTRIBUTING}.md}
- insinto /etc/prometheus
- doins documentation/examples/prometheus.yml
- insinto /usr/share/prometheus
- doins -r console_libraries consoles
- dosym ../../usr/share/prometheus/console_libraries /etc/prometheus/console_libraries
- dosym ../../usr/share/prometheus/consoles /etc/prometheus/consoles
- popd || die
-
- newinitd "${FILESDIR}"/prometheus-3.initd prometheus
- newconfd "${FILESDIR}"/prometheus.confd prometheus
- keepdir /var/log/prometheus /var/lib/prometheus
- fowners prometheus:prometheus /var/log/prometheus /var/lib/prometheus
-}
-
-pkg_postinst() {
- if has_version '<net-analyzer/prometheus-2.0.0_rc0'; then
- ewarn "Old prometheus 1.x TSDB won't be converted to the new prometheus 2.0 format"
- ewarn "Be aware that the old data currently cannot be accessed with prometheus 2.0"
- ewarn "This release requires a clean storage directory and is not compatible with"
- ewarn "files created by previous beta releases"
- fi
-}