summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2018-11-06 14:56:33 +0100
committerManuel Rüger <mrueg@gentoo.org>2018-11-06 14:56:33 +0100
commit2003bb88c8f66fcea3dce67fc2140f99821b3703 (patch)
tree4436d0e7c209fd444295cd9198b375f756538c00 /app-metrics/prometheus
parenteclass/dotnet.eclass: use dotnet@gentoo.org as MAINTAINER (diff)
downloadgentoo-2003bb88c8f66fcea3dce67fc2140f99821b3703.tar.gz
gentoo-2003bb88c8f66fcea3dce67fc2140f99821b3703.tar.bz2
gentoo-2003bb88c8f66fcea3dce67fc2140f99821b3703.zip
app-metrics/prometheus: Version bump to 2.5.0
Signed-off-by: Manuel Rüger <mrueg@gentoo.org> Package-Manager: Portage-2.3.51, Repoman-2.3.11
Diffstat (limited to 'app-metrics/prometheus')
-rw-r--r--app-metrics/prometheus/Manifest1
-rw-r--r--app-metrics/prometheus/prometheus-2.5.0.ebuild70
2 files changed, 71 insertions, 0 deletions
diff --git a/app-metrics/prometheus/Manifest b/app-metrics/prometheus/Manifest
index 40d8e0cb0e79..8226df94b539 100644
--- a/app-metrics/prometheus/Manifest
+++ b/app-metrics/prometheus/Manifest
@@ -4,3 +4,4 @@ DIST prometheus-2.4.0.tar.gz 6090871 BLAKE2B 553d3292abfc58aba11e14786892b7dfc9a
DIST prometheus-2.4.1.tar.gz 6092025 BLAKE2B 4392c3329be255dcc1cd457e13defc6a462f094c47d8032b8389ffee8a384049d58eedf7a8a8724345d01e1d6645cd58d23d1bef078458bdf4fd54bac3c85ae1 SHA512 8d09e87c1af1bde08fc0d95fb51d8b25360d8bcb40c7a4b2f4bfaf79419183a4f90773ced6f53ae9a9bae10eb00af6248acf603cb13f9ce0afb815b2b7e0a8c1
DIST prometheus-2.4.2.tar.gz 6092847 BLAKE2B 0c9f01e7bce6d406ae472a3e4b75720317a8da34715881350459d5fa52531913eecb402fec08f77f8e18b28d870316e631068077cd1118b710b37e515ef19332 SHA512 3b5d3b761ed2db1bc61225d85e2c9b7619a5fefc72b41432f2d7bc707fd0e9d84746e8ab16b30eb978de713548ca2e8c108cc7a9225ab1bd2e39741b98dd1701
DIST prometheus-2.4.3.tar.gz 6095284 BLAKE2B 9b9d54cf8ed61453d63e4b93cd81cd1c08a732b2238830aa1b83b63076205569b8f947a94d0528b910c0958bc77f98605ab3eaf98a1e93d361ea6b431d5df48c SHA512 c86ce48416d32ca4310315dd7195a6ee471244b7a9323ddc49270c2b885bda38c2922047dc8fd7d9b19c9f62f8bc788d30387d38f956cbf04130d7041f9a479b
+DIST prometheus-2.5.0.tar.gz 6123272 BLAKE2B a84b31e24f4448330af63b64ed56b8c535e790930738c0f00d7ec05ff5b49cd52bcae047cfe3a0470909397562f29662003e5b5ad0a747dc209109e360daa18d SHA512 181ef94b75717d116ae8b1307f7351eb889d153b27316e08e8cffe16cf885dbf43bd0bd4214f05e56bc33bbf53f7864721ab666f5ea4356b37a5987347c6a191
diff --git a/app-metrics/prometheus/prometheus-2.5.0.ebuild b/app-metrics/prometheus/prometheus-2.5.0.ebuild
new file mode 100644
index 000000000000..a0662bd93d29
--- /dev/null
+++ b/app-metrics/prometheus/prometheus-2.5.0.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit user golang-build golang-vcs-snapshot
+
+EGO_PN="github.com/prometheus/prometheus"
+MY_PV=${PV/_rc/-rc.}
+EGIT_COMMIT="v${MY_PV}"
+PROMETHEUS_COMMIT="67dc912"
+ARCHIVE_URI="https://${EGO_PN}/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
+KEYWORDS="~amd64"
+
+DESCRIPTION="Prometheus monitoring system and time series database"
+HOMEPAGE="https://github.com/prometheus/prometheus"
+SRC_URI="${ARCHIVE_URI}"
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE=""
+
+DEPEND="
+ >=dev-lang/go-1.10
+ dev-util/promu"
+
+PROMETHEUS_HOME="/var/lib/prometheus"
+
+RESTRICT="test"
+
+pkg_setup() {
+ enewgroup prometheus
+ enewuser prometheus -1 -1 "${PROMETHEUS_HOME}" prometheus
+}
+
+src_prepare() {
+ default
+ sed -i -e "s/{{.Revision}}/${PROMETHEUS_COMMIT}/" src/${EGO_PN}/.promu.yml || die
+}
+
+src_compile() {
+ pushd src/${EGO_PN} || die
+ GOPATH="${S}" promu build -v || die
+ popd || die
+}
+
+src_install() {
+ pushd src/${EGO_PN} || die
+ dobin promtool prometheus
+ dodoc -r {documentation,{README,CHANGELOG,CONTRIBUTING}.md}
+ insinto /etc/prometheus
+ doins documentation/examples/prometheus.yml
+ insinto /usr/share/prometheus
+ doins -r console_libraries consoles
+ dosym ../../usr/share/prometheus/console_libraries /etc/prometheus/console_libraries
+ dosym ../../usr/share/prometheus/consoles /etc/prometheus/consoles
+ popd || die
+
+ newinitd "${FILESDIR}"/prometheus-3.initd prometheus
+ newconfd "${FILESDIR}"/prometheus.confd prometheus
+ keepdir /var/log/prometheus /var/lib/prometheus
+ fowners prometheus:prometheus /var/log/prometheus /var/lib/prometheus
+}
+
+pkg_postinst() {
+ if has_version '<net-analyzer/prometheus-2.0.0_rc0'; then
+ ewarn "Old prometheus 1.x TSDB won't be converted to the new prometheus 2.0 format"
+ ewarn "Be aware that the old data currently cannot be accessed with prometheus 2.0"
+ ewarn "This release requires a clean storage directory and is not compatible with"
+ ewarn "files created by previous beta releases"
+ fi
+}